Laisser la cellule vide [Résolu]

Signaler
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
-
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
-
Bonjour,

Je tente de créer une feuille excel pour tenir à jour un compte bancaire.
Ma formule fonctionne. Je la copie sur toute la page, mais mon problème est que je voudrais que la cellule reste vide tant qu'une des cellules (débit ou crédit) n'est pas renseigné
Voilà ma formule actuelle :

=SI(A3<>" ";SOMME(F2;E3;(D3*-1));(" "))

où F = somme mise à jour, D = débit et E = crédit

Si quelqu'un accepte de m'aider, je l'en remercie d'avance !

GP

Configuration: Windows / Chrome 87.0.4280.88

8 réponses

Messages postés
3000
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 janvier 2021
831
Bonjour,

=SI(A3<>" ";SOMME(F2;E3)-D3;" ")

ou tout simplement

=SI(A3<>" ";F2+E3-D3;" ")

Cordialement
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
3
Merci pour la réponse, mais l'une ou l'autre , tout en fonctionnant, me donne le même résultat
Lorsque je recopie la formule vers le bas, en prévision des prochaines entrées, les lignes encore vierges me donnent la somme restante en F, là où je voudrais la cellule vide...
Messages postés
3000
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 janvier 2021
831
désolé je n'avais pas remarqué l'espace entre les guillemets

=SI(A3<>"";SOMME(F2;E3)-D3;"")

=SI(A3<>"";F2+E3-D3;"")

Comme ceci ça fonctionne

Cordialement
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
3
Je suis désolé, mais j'ai toujours le même résultat !
Je ne comprends pas pourquoi...
Messages postés
3000
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 janvier 2021
831
Pour y voir plus clair envoie une copie du fichier sans données confidentielles

Va dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Clic sur le bouton "CREER LE LIEN" ;
"CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Cordialement
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
3
Merci PapyLuc
Voici le lien :
https://www.cjoint.com/c/JLCm7wHSlqy
Messages postés
3000
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 janvier 2021
831
Oui vu, tu as le choix :

soit tu effaces les dates de la colonne A sur les lignes où il n'y a aucune opération et là ça fonctionne ;

soit tu changes la formule pour indiquer que si les deux cellules "crédit" et "débit" sont vides alors on laisse le "total" vide, sinon on fait l'opération "total" + "crédit" - "débit"

=SI(ET(D3="";E3="");"";SOMME(F2;E3)-D3)

https://www.cjoint.com/c/JLCnMvYAuSt

Cordialement
Messages postés
224
Date d'inscription
mardi 22 mai 2007
Statut
Membre
Dernière intervention
28 décembre 2020
3
Super ! C'est nickel. Merci pour le temps prit pour réparer tout ça !
Bonnes fêtes de fin d'année.

Cordialement,
GP