Faire un tri selon un critère dans plusieurs colonnes [Résolu]

Signaler
-
 Jonattend -
Bonjour,

Etant passionné par le train je souhaite me faire un fichier Excel dans lequel j'aurais à chaque ligne une composition que j'apprécie.
J'aurais donc dans la première colonne la loco X et dans les colonnes suivantes différentes voitures composant ce train.
Admettons maintenant qu'à la ligne 3 ce soit un train dont la 3e colonne soit une voiture restaurant, qu'à la ligne 4, 5 et 6, il n'y en ait pas, mais qu'à la ligne 7, ce soit la 8e voiture qui soit la voiture restaurant.
Je voudrais savoir de quelle manière je pourrais faire un tri pour que je ne vois les lignes comprenant une voiture resto. Donc dans le cas de mon exemple, je ne verrais que la ligne 3 et 7. Idem si je veux faire un tri afin de ne voir que les trains comportant la voiture type Y de 1ere classe.

Pouvez-vous me dire de quelle manière il serait possible de faire cela ?
L'idéal serait même que je puisse combiner plusieurs critères. Donc afficher tous les trains qui comportent une voiture resto mais aussi une voiture type Y de 1ere classe.

Merci d'avance pour vos réponse

2 réponses

Messages postés
25718
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 décembre 2020
5 690
Bonjour
difficile de vous répondre sans savoir comment est construit votre modèle
pouvez vous le déposer par exemple ici:
https://mon-pârtge>.fr et en revenant coller le lien créé sur le site
ajoutez y quelques annotations sur vos attendus
à vous lire
crdlmnt
Voici le lien, je n'avais encore rien commencé car je n'avais pas encore d'idée précise sur la façon de faire mon tableau. A la fois esthétique, et très pratique.

Donc j'ai créé quelque chose de simple pour que ce soit compréhensible.


https://mon-partage.fr/f/FDMNUO9p/
Messages postés
53007
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 janvier 2021
14 973
Bonjour.


Comme souvent dans Excel, il y a plusieurs solutions possibles. https://www.cjoint.com/c/JLBq5QLLoL6
La mienne consiste à :
- insérer une colonne après ta colonne I
- mettre en J2 la formule =NB.SI(B2:I2;"resto"),
- recopier jusqu'en J6
- lancer le tri dans la colonne J
On peut agrémenter le tableau en ajoutant de la mise en forme conditionnelle ...
Merci beaucoup, en modifiant un peu avec un menu déroulant, j'ai absolument ce que je voulais, quoique d'une manière un peu moins pratique.