Problème MSVCP140 manquant [Résolu]

Signaler
Messages postés
1831
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
17 décembre 2020
-
Messages postés
42659
Date d'inscription
dimanche 20 novembre 2011
Statut
Contributeur
Dernière intervention
6 janvier 2021
-
Bonsoir,

Je suis sous Win 10 64 bits, version 20H2; CM MSI Z390-A Pro, CG NVidia GT 730, 2 X 8Go de Ram.

J'ai monté cet ordi en mars dernier et tout marchait nickel sauf que depuis 8 jours je ne peux plus enregistrer d'écrans avec OBS Studio version 26 puis dernière version 26.1 hier.

Le 1er message d'erreur que j'ai eu avec OBS me parlait de problème d'encodeur, en suivant le tuto j'ai lu qu'il devait y avoir un problème de pilote graphique non à jour.
J'ai donc chargé et installé la mise à jour du pilote Nvidia de ma CG.

Depuis lors quand je tente de lancer OBS j'ai à chaque fois un message d'erreur me disant que MSVCP140-1dll est manquant et de réinstaller le programme ce qui ne change rien.

J'ai donc tenté de télécharger cette dll manquant et de la mettre en place dans les dossiers system32 et sys WOW64;

- dans system32 j'ai les dll suivantes :
mscvp140.dll
mscvp140_2.dll
mscvp140_clr0400.dll

- dans sys WOW 64 les suivantes :
mscvp 140.dll
mscvp 140_1.dll
mscvp 140_2.dll
mscvp 140_0400.dll
mscvp 170_codecvt-iss.dll

J'ai aussi tenté de réparer avec la commande sfc /scannow qui s'est déroulé sans rien trouver ni changer.

Et pour en finir quand le tente de remplacer les 140.dll en place par celle télécharger le Windows refuse en me disant que je n'ai pas les droits administrateurs...qu'il me semblait pourtant avoir.

Voilà, désolé de la longueur mais je voulais donner le maximum d'informations possible, donc si quelqu’un parmi vous peut et veut bien m'aider à résoudre mon problème avant que je n'en arrive à l'extrémité de tenter de réparer ou réinstaller Windows plus ensuite tous les programmes sans doute ? je lui en serais très reconnaissant.

Merci d'avance.

5 réponses

Messages postés
42659
Date d'inscription
dimanche 20 novembre 2011
Statut
Contributeur
Dernière intervention
6 janvier 2021
4 736
salut

télécharge Visual C++ Redistributable Package 2017 sur ton bureau depuis cette page --> clique ici

exécute le en tant qu'administrateur (clic droit)

après l'installation, redémarre le pc et regarde ce que ça donne pour ton message d'erreur

@+

Messages postés
1831
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
17 décembre 2020
395
Merci pour ton idée, il me semblait bien avoir déjà tenté ça aujourd'hui mais en oubliant de l'exécuter en clic droit administrateur.

Bien maintenant je n'ai plus ce message de dll manquante mais toujours impossible d’enregistrer avec OBS qui m'indique toujours l'encodeur a rencontré une erreur, c'est pourtant la dernière version 64 bits chargée hier et même en désinstallant et réinstallant et redémarrant rien ne change...

Je suppose donc, comme ce message de dll absente que ce n'est pas un problème de Windows à priori, mais plutôt de OBS qui fonctionne très bien une fois réglé mais qui est une véritable usine à gaz à mettre au point.

Je verrai ça demain, enfin plus tard dans la journée.

Merci encore.
Messages postés
42659
Date d'inscription
dimanche 20 novembre 2011
Statut
Contributeur
Dernière intervention
6 janvier 2021
4 736
salut

pour OBS Studio, j'ai vu qu'il y a beaucoup de paramètres qui peuvent engendrer des soucis...

courage pour la mise en place du logiciel

@+
Messages postés
1831
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
17 décembre 2020
395
Merci à toi @+
Messages postés
42659
Date d'inscription
dimanche 20 novembre 2011
Statut
Contributeur
Dernière intervention
6 janvier 2021
4 736
re

pas de souci pour l'aide :)

@+