Récupération d'une valeur [Résolu]

Signaler
-
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
-
Bonjour,

je suis novice en bureautique "Excel" pouvez-vous m'aider ?

j'ai une valeur (X) dans la zone "A5:A20".
je veux ramener cette valeur dans la cellule "C26", si dans la zone "AB5:AB20" une cellule porte la même valeur que la cellule "AB2".

Exemple : j'ai 'X' dans la cellule "A9", je veux retrouver la même valeur 'X' dans la cellule "C26" si la valeur dans la cellule "AB9" est égale la valeur dans la cellule "AB2".

Je vous remercie par avance.
Bien cordialement

Configuration: Windows / Edge 86.0.622.69

3 réponses

Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633
Bonsoir
=SI(AB9=$AB$2;A9;"")
sauf erreur de compréhension
crdlmnt
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633 > Anatole44
alors pour que l'on se comprenne mieux pouvez vous déposer un modèle sans données confidentielles, avec quelques explications sur les attendus par exemple ici:
https://mon-partage.fr
et revenir coller le lien créé sur le site
à vous lire
crdlmnt
>
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020

je ne suis pas très calé pour opérer ces manip de liens.
https://mon-partage.fr/f/F3PXtcSL/


j'ai la formule "C26" =RECHERCHEV(AB2;AB5:AB20;FAUX;$A9) La cellule C26 affiche #VALEUR
AB7 = AB2 la bonne donnée est en A9
Mais la valeur de AB2 qui est fixe peut être sur n'importe quelle Ligne (8.9.10 ou14) de la colonne AB
La valeur 20 en AB9 doit me renvoyer en C26 la valeur E qui se trouve en A9.

Merci VAUCLUSE
> Anatole44
Bonjour,
Je n'arrive pas a acceder a votre document.
essayez la morfule =IF(MATCH(AB2,AB5:AB25,0),A9,"")

La traduction: Dnas cette cellule (=), si (if) le contenu de cellule AB2* est parfaitement identique*** a une cellule entre AB5 et AB25** (Match(AB2*,AB5:AB25**,0***)) , elle est alors egale a A9 (.A9), sinon laisser vide (,"").


Seul probleme de cette formule, si la fonction MATCH echoue (il n'y as pas de redondance de la cellule AB2 dans le range AB5:AB20) then the #N/A error show up.
> Grimjohn
Bonjour Grimjohn,

Merci
"nous rencontrons un problème dans cette formule."
Remarque
La traduction: Dans cette cellule (=), si (if) le contenu de la cellule AB2* est parfaitement identique*** a une cellule entre AB5 et AB25** (Match(AB2*,AB5:AB25**,0***)) , renvoie la valeur contenu sur la même ligne que cette cellule** dans colonne A ($A9), sinon laisser vide (,"").
je retiens la réponse de Vaucluse
Merci et bonne fin de semaine.
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633 > Anatole44
Bonjour
vus ne pouvez pas utiliser RECHERCHEV pour trouver une valeur dans une colonne précédant la colonne de recherche
voyez si j'ai bien compris en C26 avec:
=SIERREUR(INDEX(A5:A11;EQUIV(AB2;AB5:AB11;0));"")
qui effectivement renvoie E dans votre modèle et rien si AB2 n'est pas dans le champ AB5:AB11
revenez si ça ne convient pas en expliquant pourquoi
crdlmnt
Bonjour VAUCLUSE

avec mes sincères remerciements

Yes, ça marche impec !

Merci et bonne fin de semaine
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt