Comparer deux durées

Signaler
-
Messages postés
5707
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 décembre 2020
-
Bonjour,

Un élève m'annonce un temps de course prévu (ex: 01:35) puis il réalise sa course (ex: 1:38)

Je souhaiterais que ma formule me dise "oui" si son temps réalisé correspond au temps annoncé plus ou moins 2 secondes incluses ou "non" s'il a plus ou moins de 2 secondes d'écart.

Dans mon exemple "non" car 3 secondes d'écart.

Auriez-vous svp des idées de formules pour solutionner mon problème ? Quand j'utilise "<" et ">" ça me marque "erreur".

Merci par avance pour votre aide!

2 réponses

Messages postés
1270
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
3 décembre 2020
128
Bonjour,

en A1 : 01:35
en B1 : 01:38

en C1 :
=SI(B1>A1;SI(B1-A1<=0,000694444444444444;"oui";"non");SI(B1<A1;SI(A1-B1<=0,000694444444444444;"oui";"non")))


Messages postés
5707
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 décembre 2020
2 449
Bonjour

En A1 : entrer 00:01:38
En A2 : entrer 00:01:35
(En A1 et A2, on peut adopter le format de cellule personnalisé mm:ss)

En A3 : =SI(ABS(ARRONDI((A1-A2)*24*3600;2))<=2;"oui";"non")

J'ai mis un arrondi au centième de seconde, sinon, les résultats sont faux dans certains cas extrêmes.