FONCTION SI [Résolu]

Signaler
Messages postés
2
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020
-
Messages postés
25542
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
-
Bonjour à tous,

Je sollicite votre aide car je m’arrache les cheveux depuis 7 heures sur une fonction qui me bloque dans l’avancement de mon travail.
Je vais essayer de faire simple et concis :

En colonne A (sur 15 lignes) j’ai des prénoms
En colonne D (sur 15 lignes) j’ai des motifs d’erreurs

J’aimerais que dans une cellule X je puisse avoir le nombre de fois ou :
J’ai « Contrat » en colonne D et que j’ai « Laëtitia » OU « Alexandra » OU « Karine » en colonne A

Pour faire plus claire (ou pas) j’aimerais une fonction qui me permettre de dire « Si ici j’ai ça et là-bas j’ai ça ou ça ou ça; si vrai =1;si faux =0 »

Par avance merci de votre aide et désolé pour ses explications tirées par les cheveux

2 réponses

Messages postés
25542
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
5 597
Bonjour
=NB.SI.ENS( A:A;"prénom";D:D;"contrat")
pour avoir le résultat pour un seul prénom

et si vous voulez regrouper plusieurs prénoms dans le calcul
faites une liste des prénoms à retenir, par exemple en Z1:Z3 (liste sans vide)
la formule, à limiter en nombre de lignes:
=SOMMEPROD((NB.SI($Z$1:$Z$3;$A$2:$A$15))*($D$2:$D$15="contrat"))

revenez avec des explications si ça ne convient pas
crdlmnt

crdlmnt

Messages postés
2
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020

Merci, je n’ai pas très bien compris le fonctionnement de la fonction SOMMEPROD et comment fonctionne l’imbrication des deux fonction ... mais ça fonctionne très bien !!!!!!

Milles merci pour ta réaction et ton partage
Messages postés
25542
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
5 597
Si ça peut être utile, pour mieux comprendre SOMMEPROD, voir ici
https://mon-partage.fr/f/W7OuXR29/
je passe le sujet en résolu
Bonne route