Besoin aide Excel [Résolu]

Signaler
-
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
-
Bonjour,

J'ai besoin de mettre le prix d'une prestation dans une colonne en fonction de plusieurs données.

SI
DANS LA FEUILLE OCTOBRE ET DANS « LA LIGNE E15 » = LE NOM SE RETROUVE DANS LA FEUILLE CONFIG ET DANS LE TABLEAU « PRESTATION »
ET SI
DANS LA FEUILLE OCTOBRE ET DANS « LA LIGNE F15 » = LE NOM SE RETROUVE DANS LA FEUILLE CONFIG ET DANS LE TABLEAU « HORAIRE»
DONC
LE RESULTAT = DANS LA FEUILLE « CONFIG » TROUVER LE PRIX QUI SOIT EN ACCORD AVEC LE NOM ET L’HORAIRE DANS LE TABLEAU « PRIX »

Je ne sais pas comment le mettre sous forme de formule. Quelqu'un pourrait-il m'aider ?

Merci par avance.

Elodie

Configuration: Macintosh / Safari 14.0

4 réponses

Messages postés
2881
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
27 novembre 2020
398
Bonjour,

Un fichier (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question. Et précise aussi ta version d'Excel, si ce n'est déjà fait.

Crdmt
Voici la feuille avec le problème non résolu

https://www.cjoint.com/c/JKklAg5knkB
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Bonjour
1°) pour que votre tableau de config en D:G sot utilisable par formule il faut que le nom correspondant à la rubrique soit répété sur toutes les lignes de la colonne D, sans cellule vide
2° il faut à partir de F15 en feuille OCTOBRE, vous ayez des informations possibles qui soient rigoureusement identiques à celle de F5:F39 de la feuille config
2°) vous pourrez alors utiliser cette formule en G15 de la feuille OCTOBRE:
=SOMMEPROD((config!$D$5:$D$39=E15)*(config!$F$5:$F$39=F15)*(config!$G$5:$G$39))
qui vous renverra la valeur de G de config sur la ligne qui contient E15 et F15 de OCTOBRE
revenez si ça ne convient pas, en expliquant votre problème
crdlmnt
Merci pour votre aide, ça fonctionne à merveille !
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt