Recherche valeur d'un tableau avec deux cellules identique sur les 2 feuilles

Résolu/Fermé
Shubaut - 8 nov. 2020 à 17:50
 Shubaut - 10 nov. 2020 à 07:07
Bonjour,

J'ai essayé pas mal de formule les unes dans les autres avec recherchev et si mais sans succès, du coup j'aurai besoin de votre aide.

Je vous explique mon cas:
Sur une première feuille j'ai un tableau de données avec les colonnes appelées "référence" , "client" et "qté". Dans ce tableau Il peut y avoir des lignes avec une même référence qui revient pour un client différent.
Ma question:
En reportant dans une deuxième feuille les colonnes références et client correspondant j'aimerai, sur une troisièmes colonne, rechercher la qté lorsque les cellules référence et client correspondent.

Je vous remercie d'avance pour votre aide.
A voir également:

5 réponses

Yoyo01000 Messages postés 1639 Date d'inscription samedi 2 février 2019 Statut Membre Dernière intervention 7 mars 2022 165
8 nov. 2020 à 18:03
Bonjour,

penchez vous du côté de la fonction SOMME.SI.ENS ou alors SOMMEPROD

Sinon, merci de partager votre fichier via : https://www.cjoint.com/
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 398
8 nov. 2020 à 18:07
Bonjour
pour faire un cumul d'une référence avec un client spécifique, exemple à adapter
feuil1 base de données en a référence, en B client en C quantité
feuil2 édition avec en A2 référence, en B2 client en C2 cumul avec la formule:
=SOMME.SI.ENS(Feuil1!C:C;Feuil1!A:A;A2;Feuil1!B:B;B2)
crdlmnt

0
via55 Messages postés 14408 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 5 mai 2024 2 706
8 nov. 2020 à 18:08
Bonjour

Tu peux opter pour la combinaison INDEX EQUIV en matriciel

Avec en feuil1 et feuil2 Ref en col A, client en col B et Qté en col C :
et en A2 et B2 feuil 2 la ref et le client cherchée, en C3 :

=INDEX(Feuil1!$C$2:$C$100;EQUIV(Feuil2!A2&Feuil2!B2;Feuil1!$A$2:$A$100&Feuil1!$B$2:$B$100;0))

Valider le formule par Ctrl + Maj +Entrée puisque c'est matriciel (elle se met alors automatiquement entre accolades dans la barre de formule)

Les plages de la feuille1 ne doivent pas être des colonnes entières (style A:A) mais des plages délimitées (style $A$2:$A$100)

Cdlmnt
Via
0
Je vous remercie à tous d'avoir répondu aussi vite.
C'est pour mon boulot donc je vois ça demain et vous tiens informé.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Je vous remercie, les deux formules marchent correctement.
J'ai même repris un troisième critère
0