Excel formule des SI + OU

Fermé
Student - 13 oct. 2020 à 21:10
PapyLuc51
Messages postés
3732
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2022
- 15 oct. 2020 à 12:33
Bonjour,
Voici ma question:
DATE en Cellule A2: 2017-03-15

Automatiser la colonne ANNÉE FINANCIÈRE (Cellule B2) et recopier vers le bas.
Si la date est plus grande ou égale à 2016-04-01 et plus petite que 2017-04-01
2016
Sinon
Si la date est plus grande ou égale à 2017-04-01 et plus petite que 2018-04-01
2017
Sinon
vide ("")

Configuration: Windows / Edge 86.0.622.38

3 réponses

PapyLuc51
Messages postés
3732
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2022
1 163
13 oct. 2020 à 21:28
Bonsoir,
Avec SI + ET

=SI(A2="";"";SI(ET(A2>=DATE(2016;4;1);A2<DATE(2017;4;1));2016;SI(ET(A2>=DATE(2017;4;1);A2<DATE(2018;4;1));2017;"")))


Cordialement
1
Merci je vais l’essayer ça fait 1:30 que je suis sur le même problème haha
0
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
Modifié le 14 oct. 2020 à 16:42
Bonjour Student, papyluc

=SI(ET(B2>=DATE(ANNEE(B2);4;1);B2<DATE(ANNEE(B2)+1;4;1));ANNEE(B2);"")

1
PapyLuc51
Messages postés
3732
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2022
1 163
15 oct. 2020 à 06:17
Salut Michel

Student demande l'inscription de 2016 ou 2017 sinon rien si la date inscrite se situe entre 1/4/2016 et 31/3/2018.

Tu as pensé ta formule pour toutes les dates inscrites quelle que soit l'année mais elle ne fonctionne que pour les dates entrées du 1/4 au 31/12 de l'année B2 ; la cellule reste vide si la date B2 se situe du 1/1 au 31/3.

Je pense donc que la formule devrait être :

=SI(B2<>"";SI(ET(B2>=DATE(ANNEE(B2);4;1);B2<=DATE(ANNEE(B2);12;31));ANNEE(B2);ANNEE(B2)-1);"")

B2<>"" pour éviter 1899 si la cellule est vide.

Cordialement
0
ALS35
Messages postés
917
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
21 septembre 2022
95 > PapyLuc51
Messages postés
3732
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2022

15 oct. 2020 à 09:51
Bonjour à tous,

Avec la date en B2
=SIERREUR(ANNEE(MOIS.DECALER(B2;-3));"")


Cordialement
0
PapyLuc51
Messages postés
3732
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2022
1 163
15 oct. 2020 à 12:33
Re:

Encore une autre calculée sur les trimestres pour le plaisir

=SI(B2<>"";SI(CHOISIR(MOIS(B2);1;1;1;2;2;2;3;3;3;4;4;4)>1;ANNEE(B2);ANNEE(B2)-1);"")

Cordialement
1