Excel formule des SI + OU

Signaler
-
Messages postés
2829
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 octobre 2020
-
Bonjour,
Voici ma question:
DATE en Cellule A2: 2017-03-15

Automatiser la colonne ANNÉE FINANCIÈRE (Cellule B2) et recopier vers le bas.
Si la date est plus grande ou égale à 2016-04-01 et plus petite que 2017-04-01
2016
Sinon
Si la date est plus grande ou égale à 2017-04-01 et plus petite que 2018-04-01
2017
Sinon
vide ("")

Configuration: Windows / Edge 86.0.622.38

3 réponses

Messages postés
2829
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 octobre 2020
761
Bonsoir,
Avec SI + ET

=SI(A2="";"";SI(ET(A2>=DATE(2016;4;1);A2<DATE(2017;4;1));2016;SI(ET(A2>=DATE(2017;4;1);A2<DATE(2018;4;1));2017;"")))


Cordialement
Merci je vais l’essayer ça fait 1:30 que je suis sur le même problème haha
Messages postés
16260
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2020
3 051
Bonjour Student, papyluc

=SI(ET(B2>=DATE(ANNEE(B2);4;1);B2<DATE(ANNEE(B2)+1;4;1));ANNEE(B2);"")

Messages postés
2829
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 octobre 2020
761
Salut Michel

Student demande l'inscription de 2016 ou 2017 sinon rien si la date inscrite se situe entre 1/4/2016 et 31/3/2018.

Tu as pensé ta formule pour toutes les dates inscrites quelle que soit l'année mais elle ne fonctionne que pour les dates entrées du 1/4 au 31/12 de l'année B2 ; la cellule reste vide si la date B2 se situe du 1/1 au 31/3.

Je pense donc que la formule devrait être :

=SI(B2<>"";SI(ET(B2>=DATE(ANNEE(B2);4;1);B2<=DATE(ANNEE(B2);12;31));ANNEE(B2);ANNEE(B2)-1);"")

B2<>"" pour éviter 1899 si la cellule est vide.

Cordialement
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020
23 >
Messages postés
2829
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 octobre 2020

Bonjour à tous,

Avec la date en B2
=SIERREUR(ANNEE(MOIS.DECALER(B2;-3));"")


Cordialement
Messages postés
2829
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 octobre 2020
761
Re:

Encore une autre calculée sur les trimestres pour le plaisir

=SI(B2<>"";SI(CHOISIR(MOIS(B2);1;1;1;2;2;2;3;3;3;4;4;4)>1;ANNEE(B2);ANNEE(B2)-1);"")

Cordialement