Recherche croisée

Signaler
Messages postés
19
Date d'inscription
lundi 28 octobre 2013
Statut
Membre
Dernière intervention
1 septembre 2020
-
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
-
Bonjour,

Je cherche une formule pour que la cellule J23 de l'onglet DONNEES renvoie une valeur issue de l'onglet BDD en colonne J suivant les conditions suivantes:
- si J16 est égal à une des valeurs de la colonne BDD!G:G alors la cellule correspondante sur la même ligne dans la colonne J
- si J16 n'est pas dans cette liste alors la valeur correspondante à la recherche de la cellule DONNEES!C15 dans BDD!I:I qui renverrai à la cellule en colonne G

En résumé si le code postal (DONNEES!J16) apparaît dans la liste BDD!G:G alors ça renvoi l'Eurocode correspondant (NDD!L:L) sinon c'est l'Eurocode 1 du département (DONNEES!C15) qui doit êt erenvoyé

voici le lien pour tester le fichier: https://we.tl/t-Dx0087ZYUZ

Merci de votre aide.

1 réponse

Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 231
Bonjour,

Voici la formule à intégrer dans votre cellule J23 :
- =SIERREUR(RECHERCHEV(J16;BDD!G:L;6;FAUX);DONNEES!C15)