Formule SI et ET - limité à 64 imbrications

Signaler
-
 Audrey -
Bonjour,

Je suis en difficulté sur Excel car je dois calculer le taux de rémunération de mes revendeurs par rapport au CA Global et par rapport à leur propre CA.

Ma formule est donc la suivante : =SI(ET(CA GLOBAL>X;CA INDIVIDUEL>=Y);Z%)
Sauf que j'ai 6 paliers de CA GLOBAL et 12 de CA INDIVIDUEL, ma formule ne me permet donc pas d'intégrer la totalité de mes conditions puis qu'il y en a 72...

Voici le lien du fichier :

https://www.cjoint.com/c/JIbkesr4pOT

Merci de l'aide que vous saurez m'apporter.

Audrey

2 réponses

Messages postés
17227
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 septembre 2020
4 238
Bonjour,

Le nombre d'imbrication n'a jamais été un problème sur Excel, regarde ma publication
https://www.commentcamarche.net/faq/34102-utiliser-plus-de-7-imbrications-si-dans-une-formule

en attendant je regarde ton fichier il doit y avoir mieux à faire

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Bonjour Mike,
https://forums.commentcamarche.net/register/
Merci de votre réponse, j'ai pourtant essayé avec la formule proposée dans votre topic, "&" qui en effet ne limite pas le nombre d'imbrication mais cette dernière me donne un résultat pour chaque portion de formule... Soit "FauxFauxFaux1,251,50Faux" :(
Messages postés
23485
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
6 349
Bonjour,

si j'ai bien compris :
=INDEX($F$6:$K$17;EQUIV(B21;$E$6:$E$17;1);EQUIV($B$7;$F$5:$K$5;1)) 

https://www.cjoint.com/c/JIbkt48Y4tH
eric
Bonjour Eric,

Merci, la formule fonctionne (en remplaçant le premier palier global par 0 car il doit se lire "si le CA est inférieur à" contrairement aux autres paliers).
J'étudie la formule et espère pouvoir vite la réutiliser seule!