Comment écrire une formule qui masque ou montre des lignes [Résolu]

Signaler
-
 Django4811 -
Bonjour,
J'ai une feuille qui contient des données sur une cave.
Les lignes qui ont un nombre de bouteilles = 0 prennent la couleur mauve. (je ne sais d'ailleurs plus où se trouve la formule qui permet ce changement de couleur -> dans la colonne M est indiqué le nombre de bouteilles restante Si = 0 Ligne devient mauve)
Je souhaiterais, sous la même condition, pouvoir masquer les lignes ou les afficher en fonction de oui ou non dans une case (par exemple la case M1).
Donc si Oui dans case M1 alors les lignes avec M=0 sont masquées et si Non dans case M1 alors toutes les lignes sont visibles.

Merci pour votre aide



Configuration: Macintosh / Chrome 83.0.4103.116

2 réponses

Messages postés
15343
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
20 septembre 2020
1 360
Bonjour,

pouvoir masquer les lignes ou les afficher en fonction de oui ou non
Masquer des lignes avec formule, pas possible, code en VBA:
ex ici:
https://forums.commentcamarche.net/forum/affich-25948917-excel-masquer-lignes-en-fonction-de-criteres

Probleme: si la ligne se masque automatiquement, va pas être facile de remplir les cellules qui feront changer le stock
Bonjour,
Merci pour votre réponse.
Tout d'abord, j'ai retrouvé la formule qui permet de changer la couleur de la ligne quand "reste=0" : dans mise en forme conditionnelle -> =SI($M2=0;VRAI;FAUX) qui s'applique à toute la liste.
Une telle condition n'est-elle pas applicable dans une macro ? Et pour chaque ligne de la liste ?
Maintenant, je vais regarder votre lien !
Encore merci
Bonsoir,
Finalement en fouinant sur les sites, j'ai trouvé une solution avec deux macros (avec bouton) pour masquer/montrer le lignes correspondant à la formule.
Merci pour votre aide