Somme sur 12 mois glissants [Résolu]

Signaler
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020
-
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020
-
Bonjour,

Pilote privé, j'essaye de faire un classeur excel.
Le LAPL a une validité « glissante » : pour conserver sa licence le pilote devra justifier, dans les 24 mois précédant son vol, de :
Au moins 12 heures en tant que Commandant de Bord incluant
12 décollages et 12 atterrissages. Et un cours de remise à niveau d'au moins une heure du temps de vol avec un instructeur (Double).

J'ai une colonne avec les dates, et deux colonnes différentes avec mes vols CDB, de jour et de nuit.
J'aimerais trouver une formule pour avoir en fonction de la date de mon LAPL (page pilote C6) le total de ce que j'ai fait comme CDB sur les 12 derniers mois

Merci d'avance

Configuration: Windows / Firefox 77.0

23 réponses

Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
Bonjour

En supposant les dates en A les vols de jours en B et de nuit en C
Pour avoir la somme des 12 derniers mois en vols de jour :
=SOMME.SI.ENS(B:B;A:A;">="& MOIS.DECALER(AUJOURDHUI();-12))
puis pour vols de nuit :
=SOMME.SI.ENS(C:C;A:A;">="& MOIS.DECALER(AUJOURDHUI();-12))

Cdlmnt
Via
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

Désole mais je comprend pas, pour tous vous dire je suis pas très doués avec excel

en :
B : dates de mes vol
G : heures de vol double (jour)
H : heures de vol CDB (jour)

en F 27 mais heures / 12 mois
en C 6 page pilote la date de mon LAPL

mon tableau

http://img114.xooimage.com/views/a/4/6/carnet-de-vol-578303a.png/
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
=SOMME.SI.ENS(H6:H19;B6:B19;">="& MOIS.DECALER(AUJOURDHUI();-12))
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

MERCI via55

sa fonctionne mais si je déplace la formule pour prendre le report d'heures j'ai une erreur

http://img115.xooimage.com/views/d/7/5/cndv-578309e.png/


dsle de pas être très doué
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
Il n'y a pas de date en face du report donc tu ne peux l'inclure dans la formule, il faut l'ajouter après :
=SOMME.SI.ENS(H6:H19;B6:B19;">="& MOIS.DECALER(AUJOURDHUI();-12)) + H5
mais dans ce report les heures sont-elles bien des 12 derniers mois ??
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

avec +H5 sa fonctionne bien, mais oui pas simple le report et sur plusieurs date de la page précédente

mon tableur

https://www.cjoint.com/c/JFCmJ1GzRxA
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
Oui, tu le télécharges sur cjoint.com, tu copies le lien créé et tu reviens le coller ici
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
https://www.cjoint.com/c/JFCnfU0XWSd
En espérant que cela conviendra

Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

Merci je changerais les dates pour voir ci le tableau fonctionne correctement

un Grand Merci a vous

cordialement,
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

en changent mes heures je me suis aperçu que le tableur fonctionne pas la date et pas prise en compte


https://www.cjoint.com/c/JFCnSBEO2TA
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
Qu'est ce qui ne focntionne pas ?
Attention les cellules résultats doivent bien être au format personnalisé [h]:mm:ss
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

en page 1 :
H/12 mois j'ai un 0,4 alors quand page 2 j'ai 17:37:00

je crois que le reports et pas pris en compte avec les dates et la date en page pilote qui bouge un peut tous les 2 ans

j'ai essayer de changer mes heures de vol je dois avoir :

Au moins 12 heures en tant que Commandant de Bord (CDB) incluant
12 décollages et 12 atterrissages.
Et un cours de remise à niveau d'au moins une heure du temps de vol avec un instructeur (Double).

https://www.cjoint.com/c/JFCq23MUefA
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
https://www.cjoint.com/c/JFCrO2gMXCd

J'ai mis les bons formats et les bonne formules pour le report jusqu'au carnet de vol p 5
Si tout est bon faire de même pour les pages suivantes
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

un grand MERCI

je regarde et je vous tient au courant
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

j'ai changer les dates pour voir le fonctionnement page 1 on et a 1 h / 12 mois

page 2 on et a 18 h / 12 mois la formule ne tient pas compte des dates de la page 1 elle prend juste le report.

dans la formule page 2 :

=SOMME.SI.ENS(H6:H19;B6:B19;">="& MOIS.DECALER(AUJOURDHUI();-12)) + H5

le + H5 prend le report sans aucune dates

https://www.cjoint.com/c/JFDqi2apvIA
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
https://www.cjoint.com/c/JFDqRyIU5lt
Bon jusqu'à la page de vol 3 formules et formats de cellules, à copier sur les feuilles suivantes
En H5 report du total en H24 feuille précédente
En F27 somme des heures de la feuille comprises dans les 12 derniers mois + report de F27 de la feuille précédente
Messages postés
14
Date d'inscription
dimanche 28 juin 2020
Statut
Membre
Dernière intervention
29 juin 2020

Merci

le dernier tableur fonctionne pour les heures sauf pour les dates de la pages précédente.

Peut ton mettre les date de la page précédente dans la formule ?
Messages postés
12393
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 juillet 2020
1 925
Que veux tu dire ?
Donne moi un exemple chiffré