Identifier le nombre de valeur différentes d une colonne pour la même donnée sou

Signaler
-
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
-
Bonjour,

Je cherche en vain sur les forums une formule adaptable à mon problème.
Je souhaiterai identifier les valeur différentes d une colonne pour une même donnée source.
Exemple :
En colonne A : nom et prénom
En colonne B : n°de sécurité sociale
En colonne C : n°interne de notre logiciel

La problématique est la suivante je souhaiterai identifier les valeurs différentes en colonne C pour une même valeur en colonne A ou B. Cela me permettra de connaitre les personnes que nous avons en doublons dans notre base.
Je ne sais pas si je suis assez explicite dans mes propos. N hesitez pas à me demander si vous avez besoin de plus informations.
Configuration: Android / SamsungBrowser 11.2

4 réponses

Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Bonjour

En D1 :
=NB.SI.ENS(A:A;A1;C:C;C1) te donnera le nombre de fois que cette personne se retrouve avec le même n° interne (à étirer vers le bas)
En E1:
=NB.SI.ENS(B:B,B1;C:C;C1) te donnera le nombre de fois qu’un n° SS se retrouve avec le même n° interne (à étirer vers le bas)

Ensuite tu fais trier ton tableau sur la colonne C pour voir les doublons les uns en dessous des autres (tu peux les mettre en couleur avec une mise en forme conditionnelle basée sur les colonnes C et D ayant une valeur > à 1

Cdlmnt
Via
Super merci pour votre retour rapide j essaierai demain au boulot :)
Bonjour merci pour votre retour.
Je pense que je me suis mal exprimé. En faite le probleme c'est qu une meme personne peut avoir deux n°interne different dans notre base alors que cest la même personne dans la plupart des cas c est un chiffre du n°SS qui diffère d ou mon souhait de faire deux fois la formule l une en prenant en donnee source nom et prénom et l autre en prenant le n°SS.
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Alors peut-être qu'en bâtissant un tableau ainsi :
https://mon-partage.fr/f/QM4Nt5Qi/
Merci pour votre retour via, on y est presque je souhaiterai faire ressortir uniquement les données de la colonne A donc nom et prénom qui ont deux n°interne different alors que cest la même personne est ce possible ?
> Nicolas
Si c est le même numéro interne je ne veux pas que la personne ressorte, c est normal elle peut avoir plusieurs lignes car plusieurs garanties.
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Bon alors en supposant que le premier N° interne est le bon, en D2 de mon fichier exemple remplace la formule par =A2&NB.SI(A$2:A2;A2)-1
Dans le tableau secondaire ne ressortiront que les autres entrées ayant des n)S internes différents
Merci via vraiment super sympa vous répondez très rapidement, j essaierai semaine prochaine au boulot je n ai pas d'accès à distance et ne bénéficie pas d excel a la maison. Je vous tiens au courant si j ai le résultat escompté :)
Bonjour via je viens d essayer sans succès il me ressort un chiffre par rapport au nombre de fois que la personne ressort mais pas en fonction de son n°interne une idée ?
> Nicolas
Pas en fonction de son n°interne s il est different *
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Le tri devrait être fait dans le tableau annexe
Peut être ton fichier est il légèrement différent
Poste une exemple de ton fichier sur cjoint.com, copie le lien créé et reviens le coller ici