Afficher un KOpour les valeur >+20 et un OK pour les valeurs <+20 [Résolu]

Signaler
Messages postés
69
Date d'inscription
samedi 18 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
-
Messages postés
69
Date d'inscription
samedi 18 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
-
Bonjour,

J’ai une liste des valeurs négatives et positives comme indiqué dans mon fichier Excel.

J’ai crée une colonne à coté où je souhaite faire une formule Si pour afficher le mot « KO» si la valeur est supérieure +20 et le mot « OK » si est inférieure à 20

Donc au final , les cellules A5 ,A10,A12 & A14 doivent afficher un « KO » et les autres « OK »

Pouvez-vous s’il vous plait m’aider ?

Je vous remercie par avance.

PS : j’ai personnalisé le format des cellules pour qu’elle m’affiche en Rouge et avec un + au début les chiffres Positifs et un – et en Vert les chiffres Négatifs.

Lien du fichier :
https://mon-partage.fr/f/vIfyCBTS/

Configuration: Windows / Chrome 81.0.4044.138

2 réponses

Messages postés
2884
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 novembre 2020
779
Bonjour,

Je propose :

=SI(A2<>"";SI(A2>20;"OK";"KO");"")

https://www.cjoint.com/c/JEpcvJE2LtC

mais une précision manque dans la demande, la valeur pivot de 20 doit elle être dans les (<) ou le (>)

Si c'est (>) alors ajouter un (=) dans la formule

=SI(A2<>"";SI(A2>=20;"OK";"KO");"")

Cordialement
Messages postés
2884
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 novembre 2020
779
Re:

Désolé je viens de m'apercevoir de mon erreur il faut inverser "OK" et "KO" dans les formules

Soit : =SI(A2<>"";SI(A2>20;"KO";"OK");"") - ou - =SI(A2<>"";SI(A2>=20;"KO";"OK");"") en ce qui concerne la valeur pivot

Cordialement
Messages postés
69
Date d'inscription
samedi 18 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020

Salut PapyLuc51,
Je te remercie beaucoup.Ca fonctionne bien:)
Trés bonne soirée.