Calcul RechercheV + liste déroulante [Résolu]

Signaler
Messages postés
81
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
25 juin 2020
-
Messages postés
51872
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
-
Bonjour à tous,

J'ai encore besoin de vos lumières, j'ai essayé durant 2h30 de trouver une solution, mais je n'y arrive pas.

Je crée un simulateur de calcul de frais réel (impôts), notamment pour les paniers repas, à ce titre j'ai créé un tableau avec trois lignes, ma première colonne (R10 à R12) est une liste déroulante en (Y31) chacune des lignes contient des données ainsi qu'un signe de calcul (soustraction - ou multiplier *). Pour faire court je souhaiterais que quand dans la liste déroulante l'utilisateur choisi par exemple la ligne 12 (Je vais au restaurant), Excel me donne un résultat en calculant toute la ligne et les 10 colonnes , à savoir : 13 - 4.85 * 254 - 4 * 60 = 1830 €

J'ai donc fais cette formule qui je pensais fonctionnerais puisque je l'utilise dans un autre petit simulateur (tableau) et qu'elle fonctionne (mais pas d'addition ou autres, elle me donne juste une donnée) : =RECHERCHEV(Y31;R10:AA12;2;0)

Je ne sais pas comment formuler à Excel mon besoin qu'il additionne toutes les données.
Pourriez-vous m'aider SVP ?

Capture d'écran joint.

Vous remerciant par avance.
Bien à vous tous.




Configuration: Windows / Firefox 75.0

3 réponses

Messages postés
51872
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 584
Bonjour.

Il est beaucoup plus agréable pour nous de travailler sur un fichier Excel que sur une capture d'écran inerte !
Tu nous obliges en effet à créer nous-mêmes un fichier identique à celui qui existe déjà ...

Je ne sais pas si j'ai bien compris comment fonctionne ton simulateur :
- Les lignes 1 à 30 sont définitives
- La cellule Y31 est modifiable (par liste déroulante avec 3 choix)
- Les cellules Y32 à Y36 sont définitives (et ne servent à rien !)
- La cellule Y38 contient la formule que tu nous indiques (avec les données en exemple). Cette formule est d'ailleurs fausse, et devrait s'écrire (13 - 4.85) * 254 - 4 * 60 qui a pour résultat 1830,10 alors que la tienne donne -1485,90 à cause des parenthèses manquantes !

Est-ce bien cela ? Si oui, la formule est
=(RECHERCHEV(Y31;R10:AA12;2;0)-RECHERCHEV(Y31;R10:AA12;4;0))*RECHERCHEV(Y31;R10:AA12;6;0)-RECHERCHEV(Y31;R10:AA12;8;0)*RECHERCHEV(Y31;R10:AA12;10;0)
et si tu définis le nom "pl" pour la plage R10:AA12 tu gagneras 30 caractères :
=(RECHERCHEV(Y31;pl;2;0)-RECHERCHEV(Y31;pl;4;0))*RECHERCHEV(Y31;pl;6;0)-RECHERCHEV(Y31;pl;8;0)*RECHERCHEV(Y31;pl;10;0)
Messages postés
81
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
25 juin 2020

Houaaa !!! impressionnant !

N'ayant pas eu de réponse j'ai rusé en trichant avec un autre petit tableau qui m'a permis de trouver une combine.

Toutefois j'avais mis de côté mon problème, j'ai donc inséré ta formule QUI FONCTIONNE c'est franchement balaise !
Je te remercie.

J'ai pris note de ta remarque et la prochaine fois que j'ai un soucis avec autant d'info je transférer le fichier.
Merci encore à toi !
Messages postés
51872
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 584
Re-bonjour, Jesse.

Je ne sais pas si tu es un garçon ou une fille, ton profil étant incomplètement renseigné ...

Mais comme tu sembles avoir l'esprit ouvert, je m'autorise une deuxième intervention, toujours dans le but de faciliter tes prochaines discussions dans ce forum.
Tu devrais faire comme moi ; une fois que j'ai terminé mon message, qu'il soit court ou long, avec ou sans illustration, je prends toujours le temps de le prévisualiser, pas seulement pour corriger mes fautes de frappe, d'orthographe et de grammaire, mais aussi pour raccourcir mes phrases et enlever ce qui est inutile à la compréhension de mon propos.
Ainsi, ton message initial aurait pu être plus concis, grâce à quoi nous l'aurions compris plus vite et plus aisément, sans pour autant perdre de l'information utile :
J'ai encore besoin de vos lumières, car je ne trouve pas la solution :
Je crée un simulateur de calcul de frais ; à cet effet j'ai un tableau de trois lignes ; ma première colonne (R10 à R12) est la source d'une liste déroulante placée en (Y31) ; je veux par exemple que pour le choix "Je vais au restaurant", Excel calcule 13 - 4.85 * 254 - 4 * 60 = 1830 €

Dans un autre tableau j'ai une formule qui fonctionne ; mais sans opération, juste une recherche de donnée : =RECHERCHEV(Y31;R10:AA12;2;0)

Je ne sais pas écrire la formule complète. Pourriez-vous m'aider SVP ?

Capture d'écran jointe.

Vous remerciant par avance.

Es-tu d'accord avec mon analyse et convaincu de son intérêt ?

Cordialement.
Messages postés
81
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
25 juin 2020

Bonjour,

Bien vu pour ta remarque concernant mon profil que je viens de remplir et mettre à jour, tu peux donc maintenant voir que je suis un homme lol.

Je suis tout à fait d'accord avec toi, je ne suis pas un habitué des forums.
Bien à toi et merci encore.
Messages postés
51872
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 584
Parfait !
Je pense que nous allons souvent nous croiser dans les forums de CCM, en particulier celui sur la Bureautique ...
Bonne journée (et bon déconfinement très bientôt).