Calculer nombre de valeurs différentes

[Fermé]
Signaler
-
Messages postés
17601
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 octobre 2021
-
Bonjour,

j'ai un tableau avec le code etudiant et les matières dans lesquelles ils sont inscrits, je voudrais compter le nombre d'étudiant (c'est à dire calculer le nombre de codes étudiants différents)

Pouvez-vous m'aider s'il vous plaît

Merci


Configuration: Windows / Firefox 68.0

1 réponse

Messages postés
17601
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 octobre 2021
4 783
Bonjour,

Sous réserve d'avoir bien compris la demande, exemple pour compter les valeurs sur la plage A2:A50
cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ces accolades {}

=SOMME(SI(A2:A50<>"";1/NB.SI(A2:A50;A2:A50)))

par contre si dans la plage les codes étudiants ne sont pas en doublon cette simple formule
=NB.SI(A2:A50;">0")
ou encore
=NBVAL(A2:A50)

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...