Fonction NB.SI [Résolu]

Signaler
Messages postés
1
Date d'inscription
dimanche 12 avril 2020
Statut
Membre
Dernière intervention
12 avril 2020
-
 BOUBOU_32 -
Bonjour,

Sur Excel, j'essaie de compter un nombre de chiffres en utilisant la fonction NB.SI.
J'aimerai compter l'ensemble des chiffres différents, mais pas les doublons.
Exemple :
A1 = 2 A2 = 3 A3 = 5 A4 = 5 et A5 = 8
J'aimerai connaitre la façon de trouver 4 chiffres dans ce cas, car je ne veux pas compter les doublons.
Merci par avance
BOUBOU_32

3 réponses

Messages postés
1988
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
9 juillet 2020
317
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement

Merci. Via55 m'a donné la solution.
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Bonjour

=SOMMEPROD(1/NB.SI(A1:A5;A1:A5))

Cdlment
Via
Merci Beaucoup Via55... Ça marche très bien.
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
Bonjour le fil,

si tu as des cellules vides il faudra passer par une formule matricielle à confirmer en cliquant en même temps sur trois touches Ctrl, Shift et Entrée ta formule se placera entre ces accolades {}

=SOMME(SI(A1:A20<>"";1/NB.SI(A1:A20;A1:A20);0))