Excel compter cellules qui contiennent un chiffre parmi d'autres [Résolu]

Signaler
Messages postés
2
Date d'inscription
jeudi 12 mars 2020
Statut
Membre
Dernière intervention
12 mars 2020
-
Messages postés
23499
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
-
Bonjour à tous,

J'ai besoin de compter le nombre de fois qu'apparaît le chiffre 1 dans une colonne de chiffres. Une cellule peut contenir un ou plusieurs chiffres (par exemple 1 tout seul ou 1, 3, 4...). Je veux compter le nombre de 1 seuls ou non.
J'ai mis la formule suivante : NB.SI(D2:D392;"*1*") et le résultat affiché est à O alors qu'avec la formule NB.SI(D2:D392;"1") affiche 271 mais ne compte pas les 1 qui ne sont pas seuls dans la cellule...

Est ce que quelqu'un peut m'aider?
Merci d'avance!

4 réponses

Messages postés
23499
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
6 361
Bonjour,

comme apparemment tu as toute latitude au niveau de la saisie, fais suivre tous tes nombres d'une ",".
Même s'il est seul ou en fin de liste.
A ce moment là :
=NB.SI(A:A;"*1,*")

suffira.
eric

Edit : ah, j'ai oublié que tu peux avoir la , en séparateur décimal, moins c'est le .
Si tu peux, sépare tes nombres par "- "

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
29678
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
6 758
Bonjour,

Le soucis pourrait venir du format des cellules, par défaut,
1
est un nombre,
1,2,3
est une chaine de caractères (texte) on pourrait s’accommoder de ce soucis, mais il y a un cas plus délicat
1,2
qui est un nombre.

Il faudrait créer une autre colonne, par exemple E, avec en E2 une formule
=TEXTE(D2;"standard")
qui convertit les nombres en texte, et dupliquer cette formule jusqu'en E392 et faire une formule
=NB.SI(E2:E392;"*1*")
pour trouver le résultat

A tester

Mais cela va aussi inclure une cellule qui contiendrait
21
:-/ Plusieurs valeurs dans une cellule n'est pas une solution idéale

Messages postés
2
Date d'inscription
jeudi 12 mars 2020
Statut
Membre
Dernière intervention
12 mars 2020

malheureusement j'ai des chiffres jusqu'à 13 que je ne veux pas compter comme contenant 1. Peut être qu'il faut que je remplace par des lettres?
Messages postés
9562
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 septembre 2020
1 900
Bonjour à tous les deux

Avec une fonction personnalisée (macro)
https://mon-partage.fr/f/1m3oBANk/

Cdlmnt