Formule DAX Power BI "IF" [Résolu]

Signaler
Messages postés
62
Date d'inscription
dimanche 11 février 2018
Statut
Membre
Dernière intervention
29 avril 2020
-
Messages postés
16162
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 juillet 2020
-
Bonjour,
voila j’aimerais rajouter une colonne dans ma requête (table de fait)
Dans une colonne j’ai des numéro de comptes et j’aimerai les classifier de la manières suivantes.
1. N°de Cpte 10000 à 10999 = Actifs
2. N°de Cpte 20000 à 20999 = Passifs
3 .N°de Cpte 30000 à 30999 = CA
4 .N°de Cpte 40000 à 40999 = Charges
5. N° de Cpte 50000 à50999 = Charges Salariales
etc etc
et la je coince pour trouver la solution",Syntaxe d'écriture de la formule" si quelqu'un peut me renseigner cela serait top
merci par avance

2 réponses

Messages postés
5
Date d'inscription
mardi 13 novembre 2007
Statut
Membre
Dernière intervention
19 avril 2020
2
Bonsoir,
Il faut créer une table de correspondance , puis appliquer un RECHERCHEV avec le dernier paramètre à VRAI.
=RECHERCHEV(A8;$F$1:$G$5;2;VRAI) 

Cordialement,
--
LR
Messages postés
16162
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 juillet 2020
2 985
Bonjour

=INDEX({"actif";"passif";"CA";"Charges";"salaires"};EQUIV(A2;{10000;20000;30000;40000;50000};1)) 

avec n° de compte en A2

non testé:
A2<10000