Trouver une valeur en fonction de critères dans d'autres colonnes

Signaler
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020
-
Messages postés
11486
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
-
Bonjour le forum,

Je viens ce soir en désespoir de cause pour réussir à trouver une valeur dans un tableau en fonction de critères dans d'autres colonnes avec une formule.
J'ai essayer les index equiv ou le sommeprod en vain.
je vous mets mon fichier en exemple ainsi que des explications plus précises sur le fichier.

https://www.cjoint.com/c/JBxvshjv7F6

Merci d'avance pour votre aide.

5 réponses

Messages postés
85
Date d'inscription
mercredi 1 janvier 2020
Statut
Membre
Dernière intervention
5 juillet 2020
16
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020
1
Bonjour,

Oui j'ai essayé également avec la rechercheV mais je n'arrive pas a appliquer cette fonction avec les critères variables dans d'autres colonne... Si vous pouvez m'aider, c' est pas de refus.

Merci
Messages postés
5
Date d'inscription
mardi 13 novembre 2007
Statut
Membre
Dernière intervention
19 avril 2020
2
Une solution avec des SOMMEPROD dans un tableau intermédiaire:
=SOMMEPROD((Day-1=Tab[J])*(Joueur=Tab[joueur 2])*LIGNE(Tab))

et des INDEX pour fournir les résultats :
=SI(P2<>0;INDEX(Tab[resultat J1];P2-1);SI(P3<>0;INDEX(Tab[resultat J2];P3-1);"Inco."))

Cordialement,
--
LR

Fichier joint : https://www.cjoint.com/c/JByaMsR6IwL
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020
1
Bonjour ArdusPetus,

Tout d'abord merci pour votre aide, si j'ai bien compris, je vais rencontrer un problème avec le sommeprod qui va me récupérer les résultats aux day-1 day-2 day-3 alors qu'il est possible que j'ai besoin de récupérer un résultat récent mais qui n'est pas dans les 3 dernières "journée". Je pensais faire une sorte de classement dans les dates en colonne B mais je n'arrive pas a l'appliquer, qu'en pensez vous?


Merci par avance.
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020
1 >
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020

Re,

Je viens de penser, et si j appliquais la fonction grande.valeur pour la colonne B des dates combinée à la condition si pour les prénoms en colonne C en matricielle!

Il va ensuite falloir que je dissocie la valeur à récupérer soit en colonne H si le prénom se trouve en colonne D
Ou récupérer le résultat en colonne I si le prénom se trouve en colonne E... et c’est la que je bloque :(

Merci de votre aide
Messages postés
59
Date d'inscription
mardi 8 septembre 2015
Statut
Membre
Dernière intervention
16 juin 2020
1
Bonjour à tous,

Il n’y a vraiment personne capable de m aider?

Cordialement,
Messages postés
12368
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 juillet 2020
1 918
Bonjour rorocr

En passant par un tableau intermédiaire et GRANDE.VALEUR sans matricielle
https://mon-partage.fr/f/ephNC6iL/

Cdlmnt
Via
Messages postés
12368
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 juillet 2020
1 918
Re,

ou plus complet, permet de choisir le Day et le nom, avec graphique et classement en prime
https://mon-partage.fr/f/a7wAp1DZ/

Cdlmnt
Via
Messages postés
11486
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
656
bonjour rorocr, qu'en penses-tu?