"Soustraction" Cellule vide si résultat inférieure à une valeur fixe

Fermé
KingKong - Modifié le 20 janv. 2020 à 18:09
Mike-31
Messages postés
17950
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
25 mai 2022
- 24 janv. 2020 à 17:12
Bonsoir, nouvelle formule nouveau problème :p Je suis sous Libre Office.

Malgré ma bonne volonté et après avoir tenter différentes formule je n'arrive pas à obtenir le résultat voulu..

Je possède deux valeurs en cellules AJ8 et AJ9 et j'aimerais effectuer une soustraction (AJ8-AJ9) et obtenir le résultat dans AJ11 mais que si le total est inférieure à 25, si il est supérieure à 25 alors que souhaite que la case reste vide.

Cordialement



Configuration: Windows / Chrome 79.0.3945.117

8 réponses

JCB40
Messages postés
2602
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
24 mai 2022
466
Modifié le 20 janv. 2020 à 18:15
Bonjour,
Formule à mettre dans AJ11
=SI(AJ8-AJ9<25;AJ8-AJ9;"")
Cordialement




1
yclik
Messages postés
2868
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 mai 2022
1 314
20 janv. 2020 à 18:14
bONSOIR
+si(AJ8-AJ9<=25;AJ8-AJ9;"")
1
Mais quel rapidité ! :o

Ca fonctionne merci beaucoup !

Un autre petit détail, j'ai une cellule juste en dessous en AJ12 et celle-ci affiche le résultat de AJ8+AJ9 uniquemet si AJ11 est supérieure à 0.

Voici la formule que j'utilise pour ce cas

=SOMMEPROD((AJ11>0)*AJ8:AJ9)

Néanmoins avec la formule que vous m'avez proposer quand le résultat de AJ11 est supérieure à 25 et donc la case vide, AJ12 lui a affiche toujours le résultat de AJ8+AJ9. J'aimerais donc garder la propriété de ma formule ci haut, donc si AJ11 est inférieure à 0 la case AJ12 reste vide et si AJ11 est supérieure à 25 donc case vide, je voudrais que AJ12 reste également vide. Est ce possible ?

Edit : A noter que si j'utilise la formule Sommeprod cité plus haut c'est parce que si en case AJ8 j'ai la même valeur de AJ9 alors la case AJ12 reste vide et j'aimerais garder cette fonction aussi.
0
Suite à mes petites recherche et au cas ou ça pourrait servir d'autres personnes j'ai trouvé la formule pour la question à mon message ci-haut.

La formule est :

=SOMMEPROD((AJ11>0)*(AJ11<25)*AJ8:AJ9)

Et merci à JCB40 et yclik pour leur contribution !
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Un problème en ouvre un autre : ) et par contre celui là je suis pas prêts de le résoudre tout seul.. :o

Avec la formule proposé plus haut =SI(AJ8-AJ9<25;AJ8-AJ9;"") les valeurs au dessus de 25 rende la cellule vide, jusqu’à là parfait. L'autre soucis et que j'aimerais aussi limité la même valeur, 25, mais au cas ou le résultat est négatif, donc -25. C'est à dire toute valeur plus grand que -25 ( -26,-27 etc.. ) rendrait la case vide aussi. Possible ?
0
Je n'ai toujours pas su trouver le problème à mon message ci-dessus.

En résumer j'ai deux valeurs variable en G8 et G9 et en G11 c'est le résultat de la soustraction de G8-G9.

Ma condition initial était que si le résultat est supérieure 20 la case devait être vide et ça fonctionne avec la formule que j'ai faite ci-dessous

=SI(G8-G9<=20;G8-G9;"")

J'ai ensuite eu besoin de rajouter une autre condition en plus de la première, si le résultat est supérieure à -20 la case devait être vide aussi mais avec ma formule ci dessous ca ne fonctionne pas, j'ai tenter différente formule mais en vain..

=SI(OU(G8-G9<=20;G8-G9>=-20);"";"")

Quelqu'un pourrait pointé ou ce situe mon erreur ? Merci
0
michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022
3 280
22 janv. 2020 à 09:26
Bonjour

Plutôt un "ET" qu'un "OU"
=SI(ET(G11>-20;G11<20);G11;"")
0
Bonjour Michel,

J'avais essayé la fonction ET mais ca ne fonctionnait pas non plus. Dans votre formule G11 est la case résultat de G8-G9 et dans ce cas la formule ne sait pas de quoi dépend G11. Etes vous sur de votre formule ?
0
michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022
3 280 > KingKong
Modifié le 22 janv. 2020 à 13:51
OUI
Vous avez écrit
j'ai deux valeurs variable en G8 et G9 et en G11 c'est le résultat de la soustraction de G8-G9.

que l'on marque G8-G9 ou G11 cela revient au même !!!!!!!

l
mais, au fur et à mesure de vos post les données changent AJ8-AJ9 devient G8-G9...
la limite est 25 puis 25 et -25 Puis seulement +25,puis les 25 deviennent 20....

Comme toujours j'ai fait une maquette sur Excel (à ce niveau libre-office=excel) et cela fonctionne

Votre demande est un sacré B... et nous fait perdre du temps et de la patience
0
KingKong > michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022

22 janv. 2020 à 13:49
Je comprends pas...

En G8 j'ai admettons 100 et en G9 80. G11 lui calcule G8-G9, résultat 10. Si je n'inclus pas G8 et G9 dans la case de la formule G11 comment est qu'il est censé savoir si ca ca rempli mes conditions ?
0
michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022
3 280 > KingKong
Modifié le 22 janv. 2020 à 13:55
en G11 c'est le résultat de la soustraction de G8-G9.
---> en G1 la formule est =G8-G9

Essayez le macramé, cela ira peut-^tre un peu mieux
0
KingKong > michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022

22 janv. 2020 à 14:05
Déjà j'utilise office depuis moins de 1 semaine et avant ca je n'avais pas la moindre idée de ce qu'était office...donc veuillez pardonner mon ignorance..

Que mes cases changes de AJ8 ou G8 ou peu importe et que la marge "20" "25" "-20" "-25" cela ne change strictement rien à la composition de la formule.. Ma rangé va de G à DB et je prenais simplement un exemple...

J'ai par acquis de conscience essayé votre formule est ça renvoi rien du tout...alors soit je m'exprime comme une mule soit vous avez pas compris ma demande.

Sans rancune bien évidemment et désoler si je fais perdre votre temps, ce n'est pas mon intérêt...
0
Au final c'est une simple soustraction et mon souhait initial était d'afficher le résultat supérieure à zéro que si elle est entre deux valeurs comme condition ( ex : 5 à 25 ) et d'afficher le résultat inférieure à zéro que si inférieure à -25.

Plus simple que ça je peux pas l'explique et désoler si je m'étais mal exprimer dans mes messages précédent.
      • EDIT : J'ai su trouver la formule pour les valeurs supérieure comme ci dessous


=SI(ET(O8-O9>5;O8-O9<=25);O8-O9;"")

Maintenant il me reste à intégrer la condition pour si la valeur est inférieure, je continue à chercher mais n'hésiter pas si vous avez une idée.

Merci
-1
J'ai tenté celle ci mais err:504

=SI(ET(O8-O9>5;O8-O9<=25);O8-O9;"";SI(ET(O8-O9>-1;O8-O9<-25);O8-O9;""))
0
J'ai essayé avec cette formule :

=SI(K42-K41>5;"A";SI(K42-K41<=25;"B";SI(K42-K41>-25;"C";)))

J'ai pris des lettres à titre d'exemple pour que ce soit plus clair.. Donc A et et B s'affiche correctement mais C non.. Une fois passer au dessus de -25 ca reste B. Pourtant je n'ai pas de message d'erreur dans ma formule...

Dans l'attente d'un coup de pouce..merci
0
Raymond PENTIER
Messages postés
56108
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 mai 2022
17 208 > KingKong
Modifié le 24 janv. 2020 à 16:50
Normal !
Ta demande =SI(diff>5;A;SI(diff<=25;B;SI(diff>-25;C;))), c'est un peu du n'importe quoi !
Pour une différence de 10, il faut afficher A {SI(diff>5;A } ou B {SI(diff<=25;B} ou C {SI(diff>-25;C} ?
Pour une différence de 1, il faut afficher B {SI(diff<=25;B} ou C {SI(diff>-25;C} ?

Alors reprends ton calme et ta formule, en ordonnant logiquement tes conditions :
SI(diff<-25;R1; SI(diff<5;R2; SI(diff<25;R3; R4)))
0
Raymond PENTIER
Messages postés
56108
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 mai 2022
17 208 > KingKong
24 janv. 2020 à 16:57
Pour ton message #14 de 15:23 il y a un "léger" problème ...
=SI(ET(O8-O9>5;O8-O9<=25);O8-O9;"";SI(ET(O8-O9>-1;O8-O9<-25);O8-O9;""))
comment une valeur pourrait-elle se trouver à la fois plus grande que -1 et plus petite que -25 ?

Même avec des nombres imaginaires, des nombres complexes ou des nombres irréels, ce n'est pas possible !
0
Mike-31
Messages postés
17950
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
25 mai 2022
4 948 > Raymond PENTIER
Messages postés
56108
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 mai 2022

24 janv. 2020 à 17:12
Salut Raymond,
je crois que tu n'as pas regardé tes MP
cordialement
0