Compter valeurs unique avec condition

Fermé
LaPimpa Messages postés 7 Date d'inscription mercredi 11 juillet 2018 Statut Membre Dernière intervention 20 janvier 2020 - 16 janv. 2020 à 17:20
LaPimpa Messages postés 7 Date d'inscription mercredi 11 juillet 2018 Statut Membre Dernière intervention 20 janvier 2020 - 20 janv. 2020 à 11:45
Bonjour la communauté,

La question a plusieurs fois été abordée, mais aucune des solutions trouvée ne fonctionne dans mon fichier, et votre aide me serait fort utile !

Je cherche une formule sans VBA pour compter le nombre d'entreprises uniques par secteur d'activité.

Exemple :

En colonne A : noms d'entreprises (avec des doublons)
En colonne B : le secteur d'activité de l'entreprise

- l'entreprise KIKI apparaît 4 fois (colonne A), dans la catégorie "Agroalimentaire" (colonne B)
- l'entreprise BABA apparaît 2 fois (colonne A), dans la catégorie "Agroalimentaire" (colonne B)
J'ai donc 2 entreprises uniques dans la catégorie "Agroalimentaire".

Pour calculer cela, j'ai tenté la formule suivante :

=SOMMEPROD(1/NB.SI($A1:$A1000;$A1:$1000)*(B1:B1000="Agroalimentaire"))

Cette formule me donne un résultat avec des décimales (étrange) et qui n'est pas exact.

Avez-vous une idée du problème ?

Je vous remercie !

Pimpa






Configuration: Windows / Firefox 72.0

2 réponses

DjiDji59430 Messages postés 3875 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 21 septembre 2023 612
17 janv. 2020 à 12:09
Quand tu fais ton tcd, il faut cocher en bas a gauche "ajouter au modele de donnée".
Mais cela te supprime les mises en formes automatique des dates.


Crdlmt
1
LaPimpa Messages postés 7 Date d'inscription mercredi 11 juillet 2018 Statut Membre Dernière intervention 20 janvier 2020
20 janv. 2020 à 11:45
Merci pour votre aide. Je n'ai rien obtenu en faisant ajouter au modèle de données, je n'ai pas du comprendre votre réponse, mais je suis passée par Power Pivot et cela fonctionne.

Bien à vous,
0