Comment faire une somme de x = 0,50 sinon 0 dans un planning? [Résolu/Fermé]

Signaler
-
Messages postés
2586
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 décembre 2020
-
Bonjour,

Je travaille sur un calendrier et je souhaite avoir une somme qui correspond à des demi journées.
J'essaye de transformer les x en valeur 0,50 et si pas de x ou autre valeur que ce soit égal à 0.
Pouvez-vous m'aider.

Merci

5 réponses

Messages postés
2188
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
15 janvier 2021
367
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement

Messages postés
2586
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 décembre 2020
452
Bonjour,

Je pense que ça peut basiquement se faire avec la fonction SI, si vous souhaitez plus de détails, mettez nous effectivement à disposition un fichier exemple.

A mettre en cellule de destination et remplacer A1 par la cellule contenant le x :

=SI(A1="X";0,5;0)


Cordialement.
Messages postés
3
Date d'inscription
jeudi 9 janvier 2020
Statut
Membre
Dernière intervention
9 janvier 2020



C'est bien ce que j'ai fait, mais j'ai besoin de faire la somme des x sur la ligne et les transformer en 0,5 par x.

Merci
Messages postés
2188
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
15 janvier 2021
367
Re bonjour

Formule a adapter à ton fichier et à mettre dans la cellule ou tu veux le résultat
=SOMME(NB.SI(A1:G1;"x")*0,5)
Crdlt
Messages postés
2586
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 décembre 2020
452
C'est bien pour ça qu'on avait besoin de précisions ;)
Je ne suis pas sur de comprendre, vous voulez mettre des 0.5 dans les cellule des X ?
Parce que sinon vous avez déjà ce que je pensais que vous demandiez …
=NB.SI(E9:BK9;"X")*0,5
Messages postés
3
Date d'inscription
jeudi 9 janvier 2020
Statut
Membre
Dernière intervention
9 janvier 2020

Super, merci.
Pouvez-vous m'expliquer la formule. Je ne connais pas NB.
Messages postés
2188
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
15 janvier 2021
367 >
Messages postés
3
Date d'inscription
jeudi 9 janvier 2020
Statut
Membre
Dernière intervention
9 janvier 2020

Nombre de fois que la plage E9:BK9 contient de x
Messages postés
3
Date d'inscription
jeudi 9 janvier 2020
Statut
Membre
Dernière intervention
9 janvier 2020
>
Messages postés
2188
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
15 janvier 2021

Merci beaucoup.
Messages postés
2586
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 décembre 2020
452
o_O mais c'est ce que tu à déjà mis dans ton fichier ... je m'y perd là x)