Recopier x ligne vers le bas en fonction d'un nombre d'une cellule [Résolu]

Signaler
Messages postés
193
Date d'inscription
jeudi 5 septembre 2019
Statut
Membre
Dernière intervention
9 juin 2020
-
Messages postés
2781
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
-
Bonjour a tous
un grand merci pour l'aide reçu jusqu'à maintenant
mon problème:
je voudrais recopier vers le bas, une ligne de 5 cellules en fonction d'un nombre qui est dans la 6eme cellule(au bout de la 5eme)
par exemple
4 3 6 7 8 2 je veux recopier vers le bas 2 fois 4 3 6 7 8 soit

4 3 6 7 8
4 3 6 7 8
un grand merci




4 réponses

Messages postés
2781
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
733
Bonjour,

Un essai (les nombres sont inscrits en ligne 1)

En A2 (pour recopie de A1)

=SI(NBVAL($A$1:A1)>$F$1-1;"";$A$1)

Formule a tirer vers le bas il ne reste plus qu'à modifier F1 pour voir le résulat

Cordialement
Messages postés
2098
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
23 septembre 2020
824
Bonjour
une autre piste
=SI(LIGNE()>LIGNE(A$2)+$F$2;"";A2)
Messages postés
193
Date d'inscription
jeudi 5 septembre 2019
Statut
Membre
Dernière intervention
9 juin 2020

suite a ta réponse je n'arrive pas a faire marcher la fonction
j'ai une ligne b14:f14 qui comprennent des nombre de 1 à 10
j'ai une cellule n14 qui comprend des nombre de 1 à 4
je voudrais reporter b14:f14 vers le bas si n14>1
merci d'avance
Messages postés
2781
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
733
Tu as certainement soit oublié de fixer avec " $ ", ou de rectifier les lettres des colonnes sur les formules tirées vers la droite.

en B15 =SI(NBVAL($B$14:B14)>$N$14-1;"";$B$14)
en C15 =SI(NBVAL($C$14:C14)>$N$14-1;"";$C$14)
en D15 =SI(NBVAL($D$14:D14)>$N$14-1;"";$D$14)
en E15 =SI(NBVAL($E$14:E14)>$N$14-1;"";$E$14)
en F15 =SI(NBVAL($F$14:F14)>$N$14-1;"";$F$14)

Une fois la ligne correctement inscrite sélectionner les 5 cellules et tirer vers le bas jusqu'à la ligne 17

Et si tu veux ajouter la condition si N14<=1

en B15 =SI($N$14<=1;"";SI(NBVAL($B$14:B14)>$N$14-1;"";$B$14))
en C15 =SI($N$14<=1;"";SI(NBVAL($C$14:C14)>$N$14-1;"";$C$14))
en D15 =SI($N$14<=1;"";SI(NBVAL($D$14:D14)>$N$14-1;"";$D$14))
en E15 =SI($N$14<=1;"";SI(NBVAL($E$14:E14)>$N$14-1;"";$E$14))
en F15 =SI($N$14<=1;"";SI(NBVAL($F$14:F14)>$N$14-1;"";$F$14))


Cordialement
Messages postés
193
Date d'inscription
jeudi 5 septembre 2019
Statut
Membre
Dernière intervention
9 juin 2020

super pour les 4 premières qui doivent bien être recopier mais après ça me suprime tout!
Messages postés
2781
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
733
Dans ton message #3 tu dis "j'ai une cellule n14 qui comprend des nombre de 1 à 4 "

dans ma description je n'ai tiré les formules que sur 3 lignes, si N14 doit avoir un nombre supérieur à 4 alors tirer les formules au nombre de lignes désirées et chez moi ça ne supprime rien.

https://www.cjoint.com/c/ILpnIwJK8BW

Cordialement