Problème fonction rang [Résolu]

Signaler
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
-
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
-
Bonjour la communauté,

j'utilise la fonction rang pour mon tableau pour les cellules de A2 à A249
pour la cellule A2
=RANG(E2;$E$2:$E$249;0)+NB.SI(E2:$E$2;E2)-1

le souci c'est que sur les 10 premières cellule j'arrive à avoir des doublons
pour le reste des cellules tout est ok
les cellules incriminées contienne des formules
mais si je tape dans ces cellules directement le résultat plus de doublon
J'ai essayé de modifier le format mais rien à y faire
Autre bizarrerie quand je copie la cellule A2 en B2 j’obtiens:
=RANG(E3;$E$2:$E$249;0)+NB.SI(E$2:$E3;E3)-1

pour ma part je sèche
Dans l'attente de vous lire,
je vous remercie par avance

5 réponses

Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Bonsoir yann

Quelle formules sont dans tes cellules ?

Difficile de se prononcer sans avoir le fichier
Poste un exemple de ton fichier sur mon-partage.fr, copie le lien créé et reviens le coller ici

Cdlmnt
Via

Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
le lien
https://www.cjoint.com/c/IKbvH1cYrLZ
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Oui mais je ne peux rien en faire, tes formules font référence à des feuilles que je n'ai pas et donc j'ai des erreurs VALEUR partout !

Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
voila qui devrait être mieux
https://www.cjoint.com/c/IKbwZbzkNvZ
Messages postés
51859
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
13 578
" sur les 10 premières cellule j'arrive à avoir des doublons "
Je n'ai pas constaté cela : les 10 valeurs de A2 à A11 sont toutes différentes !
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
bonjour Raymond,
dans l'exemple que je donne en effet les cellule n'ont pas forcement de doublon
mais si j'arrive avoir un chiffre identique dans les cellules de E2 à E15 par rapport au reste du tableau
ces cellules me colle un doublon
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Tu as raison cela provient bien des formules, les valeurs des deux 7 retournés en E8 et E14 ne sont pas identiques, pourquoi je n'en sait rien, j'ai mis un moment à trouver mais en fait pour corriger le problème il suffit de retaper 7 dans la cellule M8 de Pose générale c'est celle-ci qui dysfonctionnait
Par précaution retape tous les nombres de cette colonne M
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
bonjour via55
pour info la cellule M8 contient la formule
=SI(ESTERREUR(I8/K8);"0";I8/K8)


truc de dingue
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
RE,
après grosse investigation je crois que j'ai levé un loup
a priori le problème vient du chiffre 7 de la feuille pose générale
si j'obtiens 8 cela marche
si joint exemple
https://www.cjoint.com/c/IKci6p5fXxZ

truc de dingue
Messages postés
12359
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 juillet 2020
1 915
Re,

ah oui alors complète ainsi ta formule :
=SI(ESTERREUR(I8/K8);"0";ARRONDI(I8/K8;0))
là apparemment ça fonctionne
mais je ne comprend pas pourquoi ta division de 33,6 par 4,8 qui devrait donner le même résultat ne le fait pas
truc de dingue comme tu dis
si quelqu'un a une explication ...............
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
merci ça marche
comme tu dis si quelqu'un a une explication ...............
Messages postés
100
Date d'inscription
dimanche 28 mai 2017
Statut
Membre
Dernière intervention
2 mai 2020
1
le plus beau il n'y a que avec 7 que cela part en sucette