Recherche mots dans texte [Résolu/Fermé]

Signaler
-
Messages postés
12862
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 novembre 2020
-
Bonjour, à tous

J'ai un sondage sorti en tableau excel avec des cellules de texte (assez longues) et je cherche à savoir combien de fois un mot ressort.
Par exemple combien de fois j'ai satisfait dans mes 48 réponses.
Est ce possible ?

2 réponses

Messages postés
25620
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 novembre 2020
5 626
Bonjour
=NB.SI(champ;"*satisfait*")
attention aux signes
ou si vous écrivez satisfait dans une cellule:
=NB.SI(champ;"*"&cell&"*")

pour info: vous savez que vous pouvez aussi afficher uniquement les réponses contenant le texte cherché via le filtre standard:

filtre/ option "textuel" / contient..

crdlmnt
Messages postés
12862
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 novembre 2020
2 072
Bonjour

Oui, possible

Exemple, avec les réponses dans la plage B2: B50 :
=NB.SI(B2:B50;"*satisfait*")
Les * indiquant qu'il peut y avoir du texte avant et après le mot satisfait

Cdlmnt
Via