Différents prix en fonction de différentes dates

Signaler
-
Messages postés
2785
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
-
Bonjour,

J'essaie de configurer un prix dans une cellule en fonction de différentes dates, mais toutes les formules que j'essaies ne fonctionnent pas. Soit par un trop grand nombre d'éléments ou par erreur de formulation (erreur que je ne trouve pas)

Ce dont j'ai besoin c'est que mon prix soit à 115$ entre le 1er décembre 2019 et le 30 avril 2020.
À 151$ entre le 1er mai 2020 et le 30 juin 2020. À 181$ entre le 1er juillet et le 24 octobre 2020 et à 119$ entre le 25 octobre 2020 et le 31 décembre 2020.

Est-ce que quelqu'un peut m'aider?!

Merci d'avance

Configuration: Windows / Chrome 77.0.3865.90

2 réponses

Messages postés
2785
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
735
Bonjour,

Quelle formule a été employée pour qu'on puisse corriger ?

Pour une réponse appropriée rien de tel que d'avoir une copie du fichier épuré de toutes les données confidentielles

Faire créer un lien sur l'un de ces sites
https://www.cjoint.com/
https://mon-partage.fr/
https://www.transfernow.net/

Copier le lien et venir le coller sur le prochain message

Cordialement
Bonjour PapyLuc

voici la formule utilisée : =SI.CONDITIONS(B3>DATE(2019;10;1);"115";B3>DATE(2020;4;30);"151";B3>DATE(2020;6;30);"181";B3>DATE(2020;10;24);"119";FAUX;"F")


et voici mon lien : https://www.cjoint.com/c/IJCmrD8okPB
Messages postés
2785
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
735
Bonjour Vanessa

Je n'ai pas un excel assez récent pour l'utilisation de la fonction SI.CONDITIONS mais ta formule comporte une erreur de syntaxe ; il faut enlever les guillemets autour de 115 -151 - 181 - 119 pour qu'elle fonctionne car ce sont des nombres et non du texte.

Je l'ai vérifiée en utilisant LibreOffice Calc et c'est bon

=SI.CONDITIONS(B3>DATE(2019;10;1);115;B3>DATE(2020;4;30);151;B3>DATE(2020;6;30);181;B3>DATE(2020;10;24);119;FAUX;"F")

Tu peux aussi t'inspirer des autres solutions données.

Cordialement
Messages postés
2785
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
735
Bonjour,

J'ai bien relu les conditions et en fait la formule est incomplète.
en E16

=SI.CONDITIONS(OU(B3<DATE(2019;12;1);B3>DATE(2020;12;31));"F";B3<=DATE(2020;4;30);115;B3<=DATE(2020;6;30);151;B3<=DATE(2020;10;24);181;B3<=DATE(2020;12;31);119)

Cordialement
Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
5 489
Bonjour (et salut PapyLuc)

je tente en attendant le modèle
pour simplifier la formule, à adapter

30/04/2020 en Y1
30/06/2020 en Y2
24/10/2020 en Y3
31/12/2020 en Y4
en ligne en Z1:Z4 les tarifs correspondants

pour éditer le tarif en cours:

=SIERREUR(RECHERCHEV(AUJOURDHUI();$Y$1:$Z$4;2);"")

(donne une cellule vide avant le 1/12 et le tarif du 31/12 après le31/12/2020
crdlmnt
Messages postés
2785
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
24 septembre 2020
735
salut Vaucluse

Pour aller dans ton sens je mettrai plutôt le tableau de recherche Y1 à Z5

01/12/2019 115
30/04/2020 151
30/06/2020 181
24/10/2020 119
01/01/2021 0

et la formule

=SIERREUR(RECHERCHEV(AUJOURDHUI();$Y$1:$Z$5;2;1);"")