Problème NB.SI en fonction de la valeur de 2 cellule [Résolu]

Signaler
Messages postés
22
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
8 octobre 2019
-
Messages postés
22
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
8 octobre 2019
-
Bonjour,

Après avoir tout essayer je me tourne vers vous, voilà mon problème :

J'ai une plage A11:Z11 par exemple, et j'aimerais compter le nombre de fois où dans une cellule contenant par exemple "A" la cellule suivante contient "B", en gros c'est compter le nombre de fois qu'un "motif" apparaît dans une plage.

Merci d'avance pour vos réponse!

Configuration: Android / Chrome 77.0.3865.92

2 réponses

Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
Bonjour,

Un truc simple, sur la ligne du dessous (Ligne 12), si c'est un tableau en insérer une ou aller dans une zone en dehors du tableau :

une de ces deux formules en prenant le premier cas (Ligne 12)

en A12 =SI(ET(A11="A";B11="B");1;"") à incrémenter à droite jusqu'à Y12 - (pas Z12 puisqu'il n'y a rien après)

ou

=SI(A11&B11="AB";1;"") même incrémentation

Ensuite sommer la ligne 12 en AA11 et masquer la ligne 12

Cordialement
Messages postés
22
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
8 octobre 2019

Merci pour votre réponse,

J'y ai déjà penser mais le problème c'est que j'ai un très gros tableau et je trouve que ça fait beaucoup trop de formules et ça va rendre le fichier lourd.. J'aurais aimer une formule ou on compare toutes les cellule avec les suivantes et compter combien de fois "A puis B" apparaît..
Messages postés
25215
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 août 2020
5 403
Bonjour (et salut Papyluc)
directement
=SOMMEPROD((A11:Z11="A")*(B11:AA11="B"))
attention au décalage, les champs doivent être de la même dimension

crdlmnt


Messages postés
22
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
8 octobre 2019

C'est super.. C'est exactement ce que je voulais! Merci infiniment pour votre réponse!
Je passe le sujet en résolu!!