Nombre de valeurs d'une colonne avec condition dans une autre colonne [Résolu/Fermé]

Signaler
-
 Natalia -
Bonjour tout le monde !

Je suis en train de faire une synthèse des données d'un fichier :

Colonne G = Instituteur/trice
Colonne H = Cotisation estimée
Colonne I = Cotisation payée

Je cherche une formule pour compter les nombre des cellules vides sur la colonne 3 mais en respectant une contition dans la colonne 1 : "Nom de l'instituteur/trice = Mme. XXX"

Je sais le faire avec un tableau croisé dynamique mais, existe-t-il une autre formule pour le calculer ?

Un grand merci d'avance à qui pourra m'aider.

Natalia

3 réponses

Messages postés
52326
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
14 126
Pour faciliter notre réponse, prière envoyer un fichier Excel-exemple.
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 490
Bonjour

si on commence en G2, en J2
=NB.SI.ENS((G:G;G2;I:I;"")
à tirer sur la hauteur, (elle renverra le résultat toutes les fois qu'elle trouve le nom)

ou alors:
=SI(NB.SI($G$2:G2;G2)=1;NB.SI.ENS((G:G;G2;I:I;"");"")
à tirer aussi mais ne renvoie le résultat que sur la première ligne ou apparaît le nom
en variante:
=SI(NB.SI($G$2:G2;G2)=NB.SI(G:G;G2);NB.SI.ENS((G:G;G2;I:I;"");"")
qui ne renvoie que sur la dernière ligne
(attention aux $sur le 1° G2)


ou a adapter ailleurs si vous avez une liste exhaustive des noms, ou une cellule avec le nom
=NB.SI.ENS((G:G;cell;I:I;"")

crdlmn t
Super !
La dernière option m'a semblée la plus simple et ça a marché !
Merci beaucoup !