Fonction transposer en fonction d'une cellule [Résolu]

Signaler
-
Messages postés
25163
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 juillet 2020
-
Bonjour.

J'ai un fichier dont je veux transposer des valeurs en fonction d'une cellule spécifique, mais j'ai des petites erreurs au fichier.

Pour une raison que j'ignore, certaines des valeurs ( ex; 11020), j'en ai seulement la moitié qui se colle.

J'ai besoin de votre expertise.

Merci.



https://mon-partage.fr/f/ZOptzcxd/

1 réponse

Messages postés
25163
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 juillet 2020
5 349
Bonjour
vu les résultats, je vous propose plutôt celle-ci qui semble fonctionner mieux
toujours en matricielle en J5

=SIERREUR(INDEX($E$1:$E$500;PETITE.VALEUR(SI($B$1:$B$500=$I5;LIGNE($A$1:$A$500));COLONNE(A$1)));"")

commencer bien les champs en ligne 1 si vous pouvez supprimer les valeurs en E1:E4, sinon, il faut commencer INDEX en ligne 5 et recaler par un- moins 4 , car le code PETITE.VALEUR ressort le N° de ligne dans la feuille

et limitez bien tout ça aux lignes utiles, car c'est lourd, lourd!

pour info, ça donne ça (J à P)
https://mon-partage.fr/f/tacHXBBF/


crdlmnt

Vaucluse tu es une machine.

Je n'aurai jamais tes connaissances sur Excel.

Merci encore une fois.
Messages postés
25163
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 juillet 2020
5 349
Vraiment pas de quoi, ce n'est qu'une formule!
je passe le sujet en résolu
bonne route
crdlmnt