Fonction SI et ET avec plusieurs conditions [Résolu/Fermé]

Signaler
-
Messages postés
25325
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
-
Bonjour,

Je souhaite faire une formule assez complexe mais Excel n'en veut pas.

Voici ma formule :
=SI(ET(D2="A";G2="A";43;SI(ET(D2="B";G2="B";0;SI(ET(D2="A";G2="B";38;SI(ET(D2="B";G2="A";5;))))))))

En français ça donne :
Si D2 = A et G2 = A, la cellule affiche 43
Si D2 = B et G2 = B, la cellule affiche 0
Si D2 = A et G2 = B, la cellule affiche 38
Si D2 = B et G2 = A, la cellule affiche 5

Savez-vous pourquoi cela ne fonctionne pas ?

Merci par avance !

3 réponses

Messages postés
25325
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
5 500
Bonjour
... parce qu'il faut grouper les "ET" entre parenthèses, enlever au bout celles qui seront donc en trop, et éventuellement rajouter à la fin ;"" ce qui permettra d'éviter l'affichage de FAUX si aucune option n'est trouvée (sinon le point-virgule final est de trop)


=SI(ET(D2="A";G2="A");43;SI(ET(D2="B";G2="B");0;SI(ET(D2="A";G2="B");38;SI(ET(D2="B";G2="A");5;""))))

crdlmnt
Merci beaucoup !

Je galérais depuis hier soir sur cette formule et je ne trouvais aucune réponse en ligne

Bonne journée !
Messages postés
25325
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2020
5 500
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt