LibreOffice Calc - Dénombrement sur liste déroulante [Résolu/Fermé]

Signaler
Messages postés
189
Date d'inscription
lundi 18 juin 2012
Statut
Membre
Dernière intervention
18 juin 2019
-
Messages postés
189
Date d'inscription
lundi 18 juin 2012
Statut
Membre
Dernière intervention
18 juin 2019
-
Bonjour à toutes et à tous,

Voilà, j'ai 2 listes déroulantes “imbriquées” c'est à dire que la deuxième liste dépend de l'item renseigné sur la première.

J'ai besoin de dénombrer les choix sélectionnés.

Je vous joints mon fichier en espérant que vous pourrez m'aider.

D'avance merci.

https://mon-partage.fr/f/xLHxsL00/

Configuration: Linux / Firefox 67.0

5 réponses

Messages postés
17137
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
4 122
Bonsoir,

Pour ma part je ne comprends pas ta demande, tu devrais retourner un fichier avec les résultats saisis manuellement
A+

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
189
Date d'inscription
lundi 18 juin 2012
Statut
Membre
Dernière intervention
18 juin 2019
16
Coucou Mike.

Déjà, merci de t'être penché sur la question même si je n'ai pas été très limpide.

Voilà ce que je souhaiterais obtenir :



Évidemment, là, j'ai rempli les cases manuellement, mais ça serait cool que Calc me “calcule” les résultats en fonction de ce que j'ai rempli pour les personnes (dans la pratique, le tableau est bcp plus long : j'ai pas loin de 300 personnes).

Est-ce que j'ai éclairci un peu ma demande ?
Messages postés
51885
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
7 juillet 2020
13 612
Bonsoir Ehlana.

Le fait que les choix ont été obtenus ou non par des listes déroulantes de cellule n'a aucune incidence.
La preuve : le fichier que tu nous as envoyé ne contient pas de LDC ...

En A19 la formule est =NB.SI.ENS($B$10:$B$14;$A17;$C$10:$C$14;A18)
à recopier dans les 9 autres cellules.

Mes amitiés à Mike-31.
C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Messages postés
17137
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
4 122
Re, bonjour l'ami Raymond,

une autre possibilité

en A19 colle cette formule et incrémente la vers la droite
=SOMMEPROD(($B$10:$B$14=$A17)*($C$10:$C$14=A18))

etc ...
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
189
Date d'inscription
lundi 18 juin 2012
Statut
Membre
Dernière intervention
18 juin 2019
16
Impeccable.

Merci Raymond. La retraite vous réussit lol

Mike, je vais aussi essayer votre méthode mais elle me semble un tantinet plus compliquée à comprendre à mon niveau lol

Merci à vous deux, en tout cas. Super