VPN Site-To-Site Cisco RV042 no suitable connection for peer

Résolu/Fermé
CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022 - Modifié le 13 mai 2019 à 11:28
brupala Messages postés 105506 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 28 novembre 2022 - 14 mai 2019 à 21:41
Bonjour,

J'ai un petit problème au niveau d'un VPN site to site avec deux RV042..

D'un coter j'ai une 4G box et de l'autre une BBOX.


Coter 4G box :

Public 37.170.139.1XX
4G BOX
Lan 192.168.8.254
|
|
Wan 192.168.8.253
RV042
Lan 192.168.1.1
|
|
Utilisateur





Coter BBOX :

Public 89.94.66.1XX
BBOX
Lan 192.168.0.254
|
|
Wan 192.168.0.253
RV042
Lan 192.168.0.1
|
|
Utilisateur




Dans les log des deux routeur RV042, j'ai cette erreur :
BBOX:

May 13 00:14:47 2019 VPN Log (g2gips0) #47: [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
May 13 00:14:47 2019 VPN Log (g2gips0) #47: [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
May 13 00:14:47 2019 VPN Log (g2gips0) #47: Peer ID is ID_IPV4_ADDR: '192.168.8.253'
May 13 00:14:47 2019 VPN Log (g2gips0) #47: no suitable connection for peer '192.168.8.253'
May 13 00:14:47 2019 VPN Log (g2gips0) #47: no suitable connection for peer '192.168.8.253'
May 13 00:14:47 2019 VPN Log (g2gips0) #47: sending encrypted notification INVALID_ID_INFORMATION to 37.170.139.158:47555



4GBOX :

Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: Peer ID is ID_IPV4_ADDR: '192.168.0.253'
Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: no suitable connection for peer '192.168.0.253'
Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: no suitable connection for peer '192.168.0.253'
Jan 1 00:52:42 2010 VPN Log (g2gips0) #79: sending encrypted notification INVALID_ID_INFORMATION to 89.94.66.187:500


De plus les port 500 et 4500 son ouvert vers les routeur RV042.(Sur la 4gbox et la Bbox bien sure).
Les parfeu sont désactiver sur les deux RV042.

J'ai du mal a voir d'ou cela viens ...


Cordialement,
Roche Corentin

1 réponse

brupala Messages postés 105506 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 28 novembre 2022 13 731
Modifié le 13 mai 2019 à 12:26
Salut,
tu n'as pas des options vpn passthrough pour ipsec à valider dans les box ?
Faire de l'ipsec derrière un NAT, là il y en a deux en plus, ça n'est jamais facile.
Surtout qu'en plus il y a certainement un CGN (nat opérateur) dans le réseau 4G.
Et il n'y a pas d'openvpn ou autre VPN SSL dans les RV042 ... :-(

0
CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022 39
13 mai 2019 à 12:55
Salut !

Merci de la réponse, j'ai pas mal avancé je pense.

Premièrement je me suis mit en DES a lieu de 3DES des deux cotés.
De plus j'ai cocher la case NAT Traversal,

Le tunel est bien connecter maintenant, mais je n'arrive pas a ping d'un machine dans l'autres réseau (dans les deux sens)


Merci
0
brupala Messages postés 105506 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 28 novembre 2022 13 731 > CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022
13 mai 2019 à 15:16
Nat traversal, bonne idée, oui.
Pour le ping, tu peux avancer via un traceroute probablement.
0
CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022 39
13 mai 2019 à 15:57
Ok, les RV042 ne font pas traverser le ping

1 <1 ms <1 ms <1 ms 192.168.2.1
2 * * * Délai d’attente de la demande dépassé.
3 * * * Délai d’attente de la demande dépassé.
4 * * * Délai d’attente de la demande dépassé.
5 * * * Délai d’attente de la demande dépassé.
6 * * * Délai d’attente de la demande dépassé.


Que ce sois des deux coter, je trouve pas l'option ... (Parfeu désactiver)

Merci
0
CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022 39
13 mai 2019 à 16:59
Pourtant j'arrive a ping le routeur internet (Donc 4G Box et BBox) de chaque site.

Donc les RV042 laisse passer le ping, mais pas dans le tunnel ?
0
brupala Messages postés 105506 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 28 novembre 2022 13 731 > CorentinRoche Messages postés 266 Date d'inscription mercredi 1 juin 2016 Statut Membre Dernière intervention 2 novembre 2022
13 mai 2019 à 19:59
Essaie d'afficher les routes sur les cisco ....
essaie d'activer RIP.
0