Fonction ESTNA [Résolu/Fermé]

Signaler
Messages postés
112
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
5 août 2020
-
Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
-
Bonjour à tous
pouvez vous m'aider
j'ai 2 lignes B18 et B19, et je veux envoyer un résultat avec la fonction ESTNA, j'ai fais cette formule
=SI(ESTNA(RECHERCHEV(B18;prix;3;0));"";RECHERCHEV(B18;prix;3;0))
ma question si B18 et vide alors je veux le résultat de B19 et je ne sais pas comment ajouter B19 dans cette formule
merci

4 réponses

Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
6 282
Bonjour,

=SI(B18="";"";SIERREUR(RECHERCHEV(B18;prix;3;0);"")) 

eric
Bonjour à tous,

=SI(B18="";SI(ESTNA(RECHERCHEV(B18;prix;3;0));SI(ESTNA(RECHERCHEV(B19;prix;3;0));"";RECHERCHEV(B19;prix;3;0)));RECHERCHEV(B18;prix;3;0))
Messages postés
112
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
5 août 2020

hhhhhhh pour Bonjour à tous ensuite
c'est vraiment super votre solution
un grand merci gyrus
Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
6 282
Et pas la mienne ?
Messages postés
112
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
5 août 2020

sérieusement je vous remercie Monsieur eric,celle de gyrus a bien fonctionner,celle que vous m'avez proposé ne m'a pas donné le résultat exact,par contre j'ai une autre formule,je ne veux pas éxagerer si vous voulez:
j'ai deux lignes qui contiennent des formule
C1 et F1
mon souci
si C1 est vide ne m'envois pas le résultat et si F1 et vide ne m'envois pas le résultat
ici la case ou j'ai fais la formule.
case "C20" =SIERREUR((C19*C1)+(C18*F1);"")
merci
Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
6 282
Bonjour,

Ah oui, je n'avais pas vu que tu voulais celui de B19 si erreur. Complétée :
=SI(B18="";SIERREUR(RECHERCHEV(B19;prix;3;0);"");SIERREUR(RECHERCHEV(B18;prix;3;0);""))


Pour la seconde :
=SI(C1&F1="";"";C19*C1+C18*F1)
eric
Messages postés
112
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
5 août 2020

merci beaucoup Monsieur Eric
j'ai essayé cette formule mais lorsque C19 contient une valeur ,elle m'envoit le resultat,et si C18 est vide le resultat reste vide.
un grand merci
Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
6 282
Dépose ton fichier alors.
cjoint.com et coller ici le lien fourni
eric
Messages postés
112
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
5 août 2020

je vous remercie Monsieur pour votre aide. çi dessous le lien de mon classeur
vous allez trouver la case B18 et B19 comme liste déroulante, si vous choisissez une et vous lui donnez la quantité elle doit envoyé le nombre dans la case C20, mais pas les deux (B18 et B19)
https://www.cjoint.com/c/IEibLA7NYMs
Messages postés
23420
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2020
6 282
Bonjour,

Je ne comprend rien à tes explications.
De plus, il semble que tu ne veuilles qu'un seul résultat pour les lignes 18-19, et en B ce sont les même listes déroulantes. Pourquoi diable mettre 2 lignes dans ce cas ???
Si la formule à Gyrus est ok et bien prend-la.
eric