Comment mettre le total d'un colonne en haut de la feuille de calcul?

Résolu/Fermé
Signaler
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021
-
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021
-
Bonjour,

J'ai une série de calculs à faire.
Il s'agit simplement de la somme des chiffres d'une colonne.
Mais ce sera pour un nombre de lignes de plus en plus grand.
J'aimerais donc que la somme des chiffres contenus dans la colonne soit indiqué en haut de la page.
Ceci afin d'aviter de devoir insérer des lignes entre mon premier nombre et mon total

Comment faire?

Metrci d'avance.

Windows / Internet Explorer 11.0</config>

6 réponses

Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 224
Bonjour.

Je ne vois pas pourquoi tu poses la question !
Il te suffit de mettre ta formule d'addition en haut de la colonne ...
( et comme le nombre de lignes ira en augmentant, tu mets une grande valeur pour le dernier argument de la somme ).
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

on est donc bien limité dans le nombre de lignes ( dans le cas de l'exemple montré, on est limté à 999).
Danielc0 m'a répondu en mettant 1048576. je ne suis pas certain que ce nombre soit assez grand
0
Messages postés
691
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
19 janvier 2021
56 >
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

1 048 576 lignes, c'est le nombre de lignes maximum pour une feuille Excel (sauf pour les classeurs au format .xls pour lesquels il n'est que de 65000 lignes.

Daniel
0
Messages postés
691
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
19 janvier 2021
56
Bonjour,

Si tu veux mettre le total de la colonne C en C1, mets :

=SOMME(C2:C1048576)
ou, pour être plus exact :
=SOMME(INDIRECT("C2:C"&LIGNES(A:A)))
Si ton problème est de voir toujours le total, sélectioinne AA2 et clique sur Affichage, Figer les volets, Figer les volets.

Cordialement.

Daniel
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

je comprends la premiere ligne ( qui me semble logique et correcte, mais qui me limite a 1048576 lignes).
Par contre, en essayant la deuxieme formule, j'ai l'erreur "name" qui s'affiche si je dis qu'en C2 je veux le total de la colonne A
0
Messages postés
691
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
19 janvier 2021
56 >
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

Si tu utilises une version anglaise, il faut transposer la forrmule :
=SUM(INDIRECT("C2:C"&ROWS(A:A)))
Le seul intérêt de cette formule est de s'adapter, quel que soit le format du classeur, soit 65000 ou 1000000 lignes.
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

je veins d'essayer la premiere formule en G2 et en H2, voici les erreurs que je trouve:


Dans la colonne G: j'ai le message d'erreur "name"
Dans la colonne H: je n'ai pas l'addition que je souhaite
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

En fait, ce que j'ai besoin, c'est que, dans la case D3, il s'affiche le solde GLOBAL, si je met un nombre dabns la colonne B"+" ou la colonne C"-"
J'ai figé les volets pour que la ligne 3 reste visible
0
Messages postés
2740
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 janvier 2022
1 265
bonsoir
une proposition si bien compris
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

Bonjour. C'est effectivement ce que j'ai fait. Mais,dans l'exeple cité, on est limité à 2190 lignes. J'avais mis 99999. Mais cela risque d'être une valeur encore trop courte.
Je cherchais donc une formule qui me permettrait un nombre ILIMITE de lignes
0
Messages postés
24261
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2022
7 026
Bonjour,

tu n'auras jamais un nombre de lignes illimité sur une feuille qui est limitée...
(ce qui t'a été répété tout au long de ce fil)
=D2+SOMME(B:B)-SOMME(C:C) 

eric
0
Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 224
Comme tu procèdes manifestement à des calculs portant sur des millions de données, ce n'est pas avec Excel (seulement un million de lignes) que tu y parviendras.
Il te faut utiliser un calculateur numérique, comme ceux de la NASA ou de Saclay.
0
Messages postés
46
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
13 août 2021

avec 999999, ca fonctionne. merci a tous
0