=SOMME.SI.ENS accepte uniquement une cellule et non une plage en critère [Résolu/Fermé]

Signaler
Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020
-
Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020
-
Bonjour, j'aurais besoin d'un peu d'aide pour simplifier une formule excel.

L'histoire : l'objectif est de sortir des statistiques sur un jeu de carte comme sur ce site :
https://burgertokens.com/pages/keyforge-deck-analyzer?deck=LIQwTgjgrglgzgAkDgEBlAFiAJgewO6FwCBAcTBADcBTOAHwCExsAjAO3GpRGYGMAXKAW2oBVZjxD8KmagGZqARgAM8pYvkA2ddQBMcmbOn6NAFi3UjADm1yj2rTa1aArLYDs26Uq0H3lrwE5tI09HXSd7RwDpOUivGTs45wMlA1MDDWkTGRCsy2k1XTyXIA

J'ai donc 2 feuilles de calcule :
- "Liste cartes" qui contient toutes les cartes du jeu
- "Decks" qui contient 1 deck (paquet de 36 cartes) par colonnes. Chaque deck est composé de 3 factions avec leurs cartes numérotés des lignes 2 à 37...

Le 1er problème : Compter le nombre de carte (de type commune par exemple en G41) avec la fonction :
=NB.SI.ENS(NCarte;G2;Rareté;$B41)+
NB.SI.ENS(NCarte;G3;Rareté;$B41)+
[...]
NB.SI.ENS(NCarte;G36;Rareté;$B41)+
NB.SI.ENS(NCarte;G37;Rareté;$B41)

a été résolu par : =SOMMEPROD((Rareté=$B41)*(NB.SI(F$2:F$37;NCarte)))
qui devient alors beaucoup plus court, mais si vous avez d'autre solution je veux bien les connaitre.

Le 2nd problème celui pour lequel je demande votre aide (en F48 par exemple) pour calculer la somme de la force de toutes les créatures :
=SOMME.SI(NCarte;F2;Power)+
SOMME.SI(NCarte;F3;Power)+
[...]
SOMME.SI(NCarte;F36;Power)+
SOMME.SI(NCarte;F37;Power)

J'aimerais beaucoup votre aide pour raccourcir cette seconde formule.
J'ai essayé avec =SOMME.SI.ENS(Power;NCarte;D2:D37)
mais le critère en D2:D37 accepte uniquement une cellule et non une plage apparemment... :(

Merci d'avance pour vos réponses !

Lien du fichier :
http://kiwix.fr/TEMP/StatsDeckKeyforge.xlsx

2 réponses

Messages postés
1939
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 juillet 2020
134
Bonjour,

1/ Je trouve ça assez optimisé comme ça.
2/ =SOMMEPROD(Power;NB.SI(F$2:F$37;NCarte))

3/ Tu n'as rien demandé à ce sujet, mais je te conseille de limiter les plages nommées sur les lignes utilisées (de 1 à 371).

A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56991 internautes nous ont dit merci ce mois-ci

Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020

ha ok c'est sans doute de là que viens le ralentissement du 1/ il calcule peut-être pour toute les ligne de la feuille et pas seulement les 370 première
J'avais pas compris ça comme ça.
Messages postés
1939
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 juillet 2020
134
Ton fichier utilise des formules assez ambitieuses... Plus simple serait d'insérer des colonnes à côté des numéros de carte pour récupérer Rareté, Puissance,... de chaque carte par RECHERCHEV ou EQUIV.

A+
Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020

oui, je sait, j'ai essayé cette méthode qui est plus simple, et qu'une amie m'a conseillé d’ailleurs... mais ça ne me convient pas trop, ça fait une grosse manip supplémentaire à chaque ajout de deck, c'est plus contraignent...
je préfère travaillé avec une seul formule pour le moment, car j'espère pouvoir les retranscrire plus tard en PHP ou javascript ou je ne sait quoi qui me permettrait de les utilisé dans une base de donnée SQL pour les intégré sur un site comme Burger Tokens (nommé au début du post)...

voilà et puis je suis qqn d'ambitieux ;-)
Messages postés
1939
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 juillet 2020
134
Retranscrire un SOMMEPROD en php ou javascript... Je pressens mieux l'utilisation de tables décrivant les "decks"...
Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020

wé j'suis loin d'en être là, je me pose pas encore trop la question du "comment" et je m'y connait pas assez en langage de prog web pour faire tout ça moi même, mais j'ai des amis programmeurs qui pourrons m'aider en temps voulus...
Messages postés
780
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 août 2020
76
Bonjour,
pourquoi vouloir raccourcir des formules si elles fonctionnent ?!
Messages postés
14
Date d'inscription
mardi 13 juin 2017
Statut
Membre
Dernière intervention
3 juin 2020

pour pouvoir faire des copier coller de cette formule sans pour autant changer 36 fois une occurrence après l'avoir copié ! tout simplement !

imagine si je copie la formule initial avec les 37 occurrence de "commune" pour pouvoir calculer les "unco" puis les rares... c'est méga long ! alors qu'avec la seconde formule j'ai juste à changé 1 occurrence.