E: Sub-process /usr/bin/dpkg returned an error code (1) [Fermé]

Signaler
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
-
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
-
Bonjour,
Après intervention sur mon terminal on me signal des erreurs
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.

mysql-server dépend de mysql-server-5.7 ; cependant :
Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Des erreurs ont été rencontrées pendant l'exécution :
psmisc
mysql-server-5.7
gvfs-backends
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Merci pour votre aide
Configuration: Linux / Chrome 72.0.3626.96

9 réponses

Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
Hello,

Essaye un
dpkg-reconfigure  mysql-server-5.7


A plus,
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Bonjour,
J'ai cette réponse
/usr/sbin/dpkg-reconfigure: mysql-server-5.7 est cassé ou partiellement installé

Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
sudo apt install --reinstall mysql-server-5.7
Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
mysql-server-5.7 est cassé <3
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Réponse:
louis@louis-R530-R730-P530:~$ sudo apt install --reinstall mysql-server-5.7
[sudo] Mot de passe de louis :
Désolé, essayez de nouveau.
[sudo] Mot de passe de louis :
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
louis@louis-R530-R730-P530:~$

J'ai même essayé en utilisant le gestionnaire de paquets




L'informatique c'est comme les champignons, pour trouvere de paqur il faut chercher.
Si je suis là, c'est que j'ai pas trouvé
Messages postés
35691
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 547
Salut,
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
T'aurais ton gestionnaire de paquets (synaptic) ouvert en même temps par hasard ? ;-\
Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
J'ai comme l'impression que l'installation de mysql a été quitté à l’arrache et le verrou n 'a pas été supprimé.

je connais pas lock-frontend.
Execute la commande suivante et donne moi le résultat ici :
sudo lsof /var/lib/dpkg/lock{,-frontend}

Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Bonjour,
résultat :
 louis@louis-R530-R730-P530:~$ sudo lsof /var/lib/dpkg/lock{,-frontend}
[sudo] Mot de passe de louis :
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
louis@louis-R530-R730-P530:~$



@zipe31 non mon synaptique est bien fermé
Messages postés
35691
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 547
@zipe31 non mon synaptique est bien fermé
T'es sûr ?

Synaptic fermé :
$ sudo aptitude upgrade 
Les paquets suivants seront mis à jour :
tesseract-ocr-eng tesseract-ocr-fra
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
tesseract-ocr
2 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 2 115 ko d'archives. Après dépaquetage, 70,5 Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]

Synaptic ouvert :
$ sudo aptitude upgrade 
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
W: Impossible de verrouiller le fichier cache : cela est en général dû à une installation simultanée de paquets avec dpkg ou un autre outil comme APT. Ouverture en mode lecture seule : AUCUNE des modifications de l'état des paquets que vous pourrez faire ne sera conservée.
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

Synaptic ouvert :
$ sudo lsof /var/lib/dpkg/lock{,-frontend}
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
synaptic 7528 root 11uW REG 8,37 0 586 /var/lib/dpkg/lock-frontend
synaptic 7528 root 12uW REG 8,37 0 302 /var/lib/dpkg/lock

Synaptic fermé :
$ sudo lsof /var/lib/dpkg/lock{,-frontend}
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Bonjour,
Je ne sais vraiment pas ce qui s'est passé
louis@louis-R530-R730-P530:~$ sudo aptitude upgrade
sudo: aptitude : commande introuvable
louis@louis-R530-R730-P530:~$ sudo lsof /var/lib/dpkg/lock{,-frontend}
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
louis@louis-R530-R730-P530:~$

Messages postés
35691
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 547
Normal, aptitude ne doit pas être installé chez toi ;-\
Recommence avec apt-get à la place (
sudo apt-get upgrade
)
Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
Hello,

Execute les commandes suivantes 1 par 1 :
sudo killall apt apt-get
sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock*
sudo dpkg --configure -a
sudo apt update
sudo apt install --reinstall mysql-server-5.7


S'il y a encore des erreurs sur le reinstall, envoie les logs apt/dpkg via un pastbin
sudo tail -n 2000 -f /var/log/apt/term.log /var/log/dpkg.log


A plus tard,
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Bonjour,
Voilà le résultat:
louis@louis-R530-R730-P530:~$ sudo killall apt apt-get
[sudo] Mot de passe de louis :
apt: aucun processus trouvé
apt-get: aucun processus trouvé
louis@louis-R530-R730-P530:~$ sudo rm /var/lib/apt/lists/lock
louis@louis-R530-R730-P530:~$ sudo rm /var/cache/apt/archives/lock
rm: impossible de supprimer '/var/cache/apt/archives/lock': Aucun fichier ou dossier de ce type
louis@louis-R530-R730-P530:~$ sudo rm /var/lib/dpkg/lock*
louis@louis-R530-R730-P530:~$ sudo dpkg --configure -a
dpkg: erreur de traitement du paquet psmisc (--configure) :
le paquet est dans un état vraiment incohérent; vous devriez
le réinstaller avant de tenter de le configurer.
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server-5.7 :
mysql-server-5.7 dépend de psmisc ; cependant :
Le paquet psmisc n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gvfs-backends :
gvfs-backends dépend de psmisc ; cependant :
Le paquet psmisc n'est pas encore configuré.

dpkg: erreur de traitement du paquet gvfs-backends (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
mysql-server dépend de mysql-server-5.7 ; cependant :
Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
psmisc
mysql-server-5.7
gvfs-backends
mysql-server
louis@louis-R530-R730-P530:~$ sudo apt update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu/ bionic InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease
Atteint:3 http://fr.archive.ubuntu.com/ubuntu/ bionic-updates InRelease
Atteint:4 http://dl.google.com/linux/chrome/deb stable Release
Atteint:5 http://fr.archive.ubuntu.com/ubuntu/ bionic-backports InRelease
Atteint:6 http://security.ubuntu.com/ubuntu/ bionic-security InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
18 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
louis@louis-R530-R730-P530:~$ sudo apt install --reinstall mysql-server-5.7
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
louis@louis-R530-R730-P530:~$
louis@louis-R530-R730-P530:~$ apt list --upgradable
En train de lister... Fait
duplicity/bionic-updates 0.7.17-0ubuntu1.1 amd64 [pouvant être mis à jour depuis : 0.7.17-0ubuntu1]
libpci3/bionic-updates 1:3.5.2-1ubuntu1.1 amd64 [pouvant être mis à jour depuis : 1:3.5.2-1ubuntu1]
pciutils/bionic-updates 1:3.5.2-1ubuntu1.1 amd64 [pouvant être mis à jour depuis : 1:3.5.2-1ubuntu1]
louis@louis-R530-R730-P530:~$


Pout:
S'il y a encore des erreurs sur le reinstall, envoie les logs apt/dpkg via un pastbin 
sudo tail -n 2000 -f /var/log/apt/term.log /var/log/dpkg.log

à 23h00 hier soir il tournait encore
Messages postés
1458
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
18 août 2020
109
Salut,

c'est normal, la commande tail permet de lire de façon 'continue' un fichier au fur est à mesure des écritures..
man tail
(q pour quitter)

De ce qu'on peut lire lors de la reconfiguration des paquets, le problème vient du paquet " psmisc". Qui, par effet boule de neige, plante MySQL et gvfs-backends.

As tu installé mysql depuis le backport bionic ?

Essaye ça :
sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock*

sudo apt install --reinstall psmisc
sudo dpkg --configure -a


A plus tard,
Messages postés
467
Date d'inscription
mardi 11 novembre 2003
Statut
Membre
Dernière intervention
10 septembre 2020
13
Bonjour,
Je pense que tout s'est bien passé
louis@louis-R530-R730-P530:~$ sudo rm /var/lib/apt/lists/lock
[sudo] Mot de passe de louis :
louis@louis-R530-R730-P530:~$ sudo rm /var/cache/apt/archives/lock
louis@louis-R530-R730-P530:~$ sudo rm /var/lib/dpkg/lock*
louis@louis-R530-R730-P530:~$ sudo apt install --reinstall psmisc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 3 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/52,5 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 226242 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../psmisc_23.1-1ubuntu0.1_amd64.deb ...
Dépaquetage de psmisc (23.1-1ubuntu0.1) sur (23.1-1ubuntu0.1) ...
Paramétrage de psmisc (23.1-1ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Paramétrage de mysql-server-5.7 (5.7.25-0ubuntu0.18.04.2) ...
Installation de la nouvelle version du fichier de configuration /etc/apparmor.d/usr.sbin.mysqld ...
Installation de la nouvelle version du fichier de configuration /etc/init.d/mysql ...
Installation de la nouvelle version du fichier de configuration /etc/logrotate.d/mysql-server ...
Installation de la nouvelle version du fichier de configuration /etc/mysql/debian-start ...
Packaging maintenance of MySQL will stop and the daemon disabled to prevent damage to your system.
For help, see /etc/mysql/FROZEN
Paramétrage de gvfs-backends (1.36.1-0ubuntu1.3) ...
Paramétrage de mysql-server (5.7.25-0ubuntu0.18.04.2) ...
Traitement des actions différées (« triggers ») pour systemd (237-3ubuntu10.13) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
louis@louis-R530-R730-P530:~$ sudo dpkg --configure -a
louis@louis-R530-R730-P530:~$



Merci @+