E: Sub-process /usr/bin/dpkg returned an erro [Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 6 janvier 2006
Statut
Membre
Dernière intervention
6 janvier 2006
-
Messages postés
1
Date d'inscription
dimanche 24 novembre 2013
Statut
Membre
Dernière intervention
24 novembre 2013
-
Salut à tous,

J'ai un problème :

leo://var/cache/apt/archives# apt-get install nmap
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les NOUVEAUX paquets suivants seront installés :
nmap
0 mis à jour, 1 nouvellement installés, 0 à enlever et 328 non mis à jour.
Il est nécessaire de prendre 709ko dans les archives.
Après dépaquetage, 2351ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 [ftp.fr.debian.org] unstable/main nmap 3.95-1 [709kB]
709ko réceptionnés en 3s (189ko/s)
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/nmap_3.95-1_i386.deb (--unpack) :
files list file for package `libgconf2-4' is missing final newline
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nmap_3.95-1_i386.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

même en faisant un

leo://var/cache/apt/archives# apt-get install libgconf2-4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
gconf2-common
Les NOUVEAUX paquets suivants seront installés :
gconf2-common
Les paquets suivants seront mis à jour :
libgconf2-4
1 mis à jour, 1 nouvellement installés, 0 à enlever et 327 non mis à jour.
Il est nécessaire de prendre 1496ko dans les archives.
Après dépaquetage, 4596ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de : 1 [ftp.fr.debian.org] unstable/main gconf2-common 2.12.1-6 [1279kB]
Réception de : 2 [ftp.fr.debian.org] unstable/main libgconf2-4 2.12.1-6 [217kB]
1496ko réceptionnés en 7s (206ko/s)
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/gconf2-common_2.12.1-6_all.deb (--unpack) :
files list file for package `libgconf2-4' is missing final newline
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/gconf2-common_2.12.1-6_all.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)
leo://var/cache/apt/archives#

idem avec un dpkg -i j'ai le même résultat.

Que puis je faire ?

amicalement


smith

10 réponses

meme problème rencontré avec samba et winbind.

Personellement j'ai optépour une solution radicale mais qui s'est avérée efficace : aptitude remove dpkg

yes a toute ls questions, puis aptitude install dpkg.

J'ai de nouveau lancé l'install de samba et winbind et magie : plus aucun problème.
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
186
Date d'inscription
dimanche 28 septembre 2008
Statut
Membre
Dernière intervention
19 février 2018
16
Désolé de ré up se post mais je tenais à dire que cela fonctionne et je voulais te dire un grand merci !!
Messages postés
1
Date d'inscription
dimanche 24 novembre 2013
Statut
Membre
Dernière intervention
24 novembre 2013

Le terminal me dit:

Les paquets ESSENTIELS suivants vont être ENLEVÉS !
dpkg

ATTENTION : la réalisation de cette action va probablement casser votre
système !
Ne PAS poursuivre à moins que vous ne sachiez EXACTEMENT ce
que vous faites !
Pour continuer, entrer la phrase « Je suis conscient que c'est une très mauvaise idée » :

J'ai un peu peur de ce que cela peut donner!!
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
291
Salut!

j'ai eu le meme type de problème il n'y a pas si longtemps.... du coup, je suis moyennement optimiste pour une résolution simple du problème, mais dans un premier temps, tu peux essayer d'effacer le paquet :
rm /var/cache/apt/archives/gconf2-common_2.12.1-6_all.deb

et recommencer la manoeuvre (si jamais le paquet est corrompu)
tu peux aussi vérifier sur les listes mails debian s'il y a un bug avec ce paquet....et attendre eventuellement attendre la version suivante pour voir si ca résoud ton problème...

sinon :
http://www.commentcamarche.net/forum/affich-1858521-[debian]-xorg-impossible-a-reinstaller

Phiphi
Messages postés
3
Date d'inscription
vendredi 6 janvier 2006
Statut
Membre
Dernière intervention
6 janvier 2006

J'ai déjà essayer de virer les paquetages.
Mais à chaque fois que je veux réinstaller quelques choses j'ai

(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/nmap_3.95-1_i386.deb (--unpack) :
files list file for package `libgconf2-4' is missing final newline
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nmap_3.95-1_i386.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.

je fais un find / -name pour retrouver les apels aux paquetage foireux et les virer.

Comment as tu fait pour t'en sortir ?
essayez ceci:

#sudo chmod 755 /usr/bin/dpkg

j'espère que ça va marcher !
Pour ceux qui ont rencontré l'erreur "short read on buffer copy" (ou sa traduction hasardeuse "lecture courte"), il s'agit simplement de fichiers .deb corrompus, cf cet article:
http://raphaelhertzog.com/2011/06/27/deciphering-one-of-dpkgs-weirdest-errors-short-read-on-buffer-copy/
Messages postés
3
Date d'inscription
vendredi 6 janvier 2006
Statut
Membre
Dernière intervention
6 janvier 2006

j'ai ait un

leo:~# find / -name *libgconf2-4*
/var/lib/dpkg/info/libgconf2-4.shlibs
/var/lib/dpkg/info/libgconf2-4.list
/var/lib/dpkg/info/libgconf2-4.postinst
/var/lib/dpkg/info/libgconf2-4.postrm
/var/lib/dpkg/info/libgconf2-4.md5sums
/usr/share/doc/libgconf2-4
/usr/share/lintian/overrides/libgconf2-4

et hop un rm qui va bien à la bourrin
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
291
Pour m'en sortir, j'avais dû reinitialiser toute la liste apt ..... un truc a casser la debian completement....donc il y a les liens dans ce que je t'avais mis, mais je ne le conseille que comme dernier recours...

Phiphi
Messages postés
84
Date d'inscription
jeudi 12 juillet 2007
Statut
Membre
Dernière intervention
21 mai 2010
18
Paramétrage de firestarter (1.0.3-1.3) ...
Starting the Firestarter firewall: failed.
invoke-rc.d: initscript firestarter, action "start" failed.
dpkg : erreur de traitement de firestarter (--configure) :
le sous-processus post-installation script a retourné une erreur de sortie d'état 100
Des erreurs ont été rencontrées pendant l'exécution :
firestarter
E: Sub-process /usr/bin/dpkg returned an error code (1)


Bonjour à tous et à toutes !! Voilà l'erreur qui m'empêche d'upgrader pour pouvoir mettre "qemu" et emuler XP pour quelques utilitaires...Si qqu'un aurait une chtite idée, je suis prenant...C'est l'eeepc de ma chérie, et je n'ai vraiment pas envie de tout réinstaller...Ya trop de trucs depuyis sur lesquelsje me suis bien pris la tête...Merci "allavansse"à celui ou celle qui pourra m'aider..Encore MERCI d'avance!

Bidi62 vous souhaite beaucoup de Bonheur, et un bon week-end ;-)
Salut a tous!!

beh voila j'ai le meme probleme mais cette fois avec le paquet samba-doc!!

j'ai resolu le probleme avec la commande suivante ::

sudo apt-get clean


je crois que le paquet est corrompu ?


voila le log

deathless@deathless:~$ sudo apt-get install -f samba-doc
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
python-crypto python-zopeinterface menu python-twisted-core
python-twisted-web2 libglitz-glx1 python-clientform libwxgtk2.8-0
python-docutils python-roman linux-headers-2.6.24-17-generic libapr1
python-mechanize python2.4-minimal python2.4 ppthtml python-tz
classpath-gtkpeer libwxbase2.8-0 python-twisted-conch libcrypto++7 libglitz1
classpath-common libgeoip1 cacao amule-common classpath libaprutil1
linux-headers-2.6.24-17 python-twisted-bin catdoc
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
samba-doc
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/7008kB of archives.
After this operation, 0B of additional disk space will be used.
(Reading database ... 323554 files and directories currently installed.)
Preparing to replace samba-doc 3.0.28a-1ubuntu4 (using .../samba-doc_3.0.28a-1ubuntu4.1_all.deb) ...
Unpacking replacement samba-doc ...
dpkg-deb (subprocess): error in buffer_read(stream): failed to write to pipe in copy: Input/output error
dpkg-deb: subprocess paste returned error exit status 2
dpkg: error processing /var/cache/apt/archives/samba-doc_3.0.28a-1ubuntu4.1_all.deb (--unpack):
short read in buffer_copy (backend dpkg-deb during `./usr/share/doc/samba-doc/htmldocs/using_samba/figs/sam2_0350.gif')
Errors were encountered while processing:
/var/cache/apt/archives/samba-doc_3.0.28a-1ubuntu4.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
deathless@deathless:~$ sudo apt-get clean
deathless@deathless:~$ sudo apt-get install -f samba-doc
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
python-crypto python-zopeinterface menu python-twisted-core
python-twisted-web2 libglitz-glx1 python-clientform libwxgtk2.8-0
python-docutils python-roman linux-headers-2.6.24-17-generic libapr1
python-mechanize python2.4-minimal python2.4 ppthtml python-tz
classpath-gtkpeer libwxbase2.8-0 python-twisted-conch libcrypto++7 libglitz1
classpath-common libgeoip1 cacao amule-common classpath libaprutil1
linux-headers-2.6.24-17 python-twisted-bin catdoc
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
samba-doc
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 7008kB of archives.
After this operation, 0B of additional disk space will be used.
Get:1 http://archive.ubuntu.com hardy-proposed/main samba-doc 3.0.28a-1ubuntu4.1 [7008kB]
Fetched 7008kB in 6s (1071kB/s)
(Reading database ... 323554 files and directories currently installed.)
Preparing to replace samba-doc 3.0.28a-1ubuntu4 (using .../samba-doc_3.0.28a-1ubuntu4.1_all.deb) ...
Ignoring nonregistered document `samba-by-example'
Ignoring nonregistered document `samba-developers-guide'
Ignoring nonregistered document `samba-using'
Ignoring nonregistered document `samba-howto'
Unpacking replacement samba-doc ...
Setting up samba-doc (3.0.28a-1ubuntu4.1) ...

deathless@deathless:~$
j'ai eu le meme probleme

jeremy@jeremy-desktop:~$ sudo apt-get -f install 
Lecture des listes de paquets... Fait 
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait 
Correction des dépendances... Fait 
Les paquets supplémentaires suivants seront installés :  
  libc6 libc6-i686 
Paquets suggérés : 
  glibc-doc 
Les paquets suivants seront mis à jour : 
  libc6 libc6-i686 
2 mis à jour, 0 nouvellement installés, 0 à enlever et 119 non mis à jour. 
1 partiellement installés ou enlevés. 
Il est nécessaire de prendre 0o/5 007ko dans les archives. 
Après cette opération, 0o d'espace disque supplémentaires seront utilisés. 
Souhaitez-vous continuer [O/n] ?  
Préconfiguration des paquets... 
(Lecture de la base de données... 126281 fichiers et répertoires déjà installés.) 
Préparation du remplacement de libc6 2.11.1-0ubuntu7 (en utilisant .../libc6_2.11.1-0ubuntu7.1_i386.deb) ... 
Dépaquetage de la mise à jour de libc6 ... 
dpkg-deb (sous-processus) : échec dans « buffer_read(stream) » : impossible d'écrire dans le tube pour copie: Erreur d'entrée/sortie 
dpkg-deb: le sous-processus coller a retourné une erreur de sortie d'état 2 
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.1_i386.deb (--unpack) : 
 lecture courte (short read) dans « buffer_copy » (backend dpkg-deb pendant « ./lib/ld-2.11.1.so ») 
Des erreurs ont été rencontrées pendant l'exécution : 
 /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.1_i386.deb 
E: Sub-process /usr/bin/dpkg returned an error code (1)  

puis j'ai fais

<code>jeremy@jeremy-desktop:~$ sudo rm /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.1_i386.deb
j'ai exactement le méme probléme que toi smith50 !! j'ai tout essayé, meme avec Aptitude ^^'
l'erreur se produit avec n'importe quel parquet
si quelqu'un sait comment fixer sa, qu'il le dise....

Phiphi57 : que veut tu dire par "reinitialiser toutes la liste apt" ??
apt-get update (ou clean) : sa marche pas
apt-get install -f : marche pas
sudo dpkg-reconfigure -a : marche pas non plus