Extraire un mot dans une chaîne de caractères

Résolu/Fermé
garfieldu38 Messages postés 11 Date d'inscription mardi 22 janvier 2019 Statut Membre Dernière intervention 7 février 2019 - 22 janv. 2019 à 16:42
garfieldu38 Messages postés 11 Date d'inscription mardi 22 janvier 2019 Statut Membre Dernière intervention 7 février 2019 - 23 janv. 2019 à 10:32
Bonjour à tous,

Je cherche à extraire le 4ème mot d'une liste de référence ci-dessous.
J'ai essayé de combiner les fonctions stxt, cherche, gauche, droite, nbcar mais rien à faire...
(mon problème est que la taille de mon 4ème mot varie entre 6 et 8 caractères,

BASK 657431 60 ML574HVA 10 PIGMENT 481
BASK 657481 60 U220EA 8 BLACK 00
...
...

...

Mes idées

1) =STXT(H8;CHERCHE(" ";[ma case];13);9)
Mais cela me sort U220EA 8 au lieu de U220EA pour la 2ème ligne

2)Dans un forum j'ai trouvé un début de réponse mais cela n'a pas l'air de fonctionner ...
(phrase en A1 et position du mot en B1)


=SI(B1>NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""));DROITE(A1;NBCAR(A1)-TROUVE("^^";SUBSTITUE(A1;" ";"^^";NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";"")))));SI(B1=1;STXT(A1;1;TROUVE("^^";SUBSTITUE(A1;" ";"^^";1))-1);STXT(A1;TROUVE("^^";SUBSTITUE(A1;" ";"^^";B1-1))+1;TROUVE("^^";SUBSTITUE(A1;" ";"^^";B1))-TROUVE("^^";SUBSTITUE(A1;" ";"^^";B1-1))-1)))

Merci d'avance !

3 réponses

ThauTheme Messages postés 1442 Date d'inscription mardi 21 octobre 2014 Statut Membre Dernière intervention 29 juillet 2022 159
22 janv. 2019 à 17:27
Bonjour Garfield, bonjour le forum,

Une solution VBA t'intéresse-t-elle ?
Qu'est-ce qu'un "mot" pour toi ? uniquement alphabétique entre le numérique (ML ou HVA) ou un mélange numérique/alphabétique séparé par un espace (ML574HVA) ?
1
garfieldu38 Messages postés 11 Date d'inscription mardi 22 janvier 2019 Statut Membre Dernière intervention 7 février 2019
22 janv. 2019 à 18:26
c'est le mélange numérique/alphanumérique qui m'intéresse"ML574HVA" (la référence de mon produit) !

je me tourne vers le VBA car je n'ai pas réussi en classique pourtant j'y suis presque (cf idée 1) : le fait que ma référence fasse entre 6 et 8 caractères rend les choses compliquées ..

merci beaucoup pour ta réponse !
0
garfieldu38 Messages postés 11 Date d'inscription mardi 22 janvier 2019 Statut Membre Dernière intervention 7 février 2019
22 janv. 2019 à 18:33
j'ai essayé ça mais quand ma référence fait 7 caractères j'ai un espace en trop et si elle fait 6 j'ai un espace et un caractère en trop...

0
garfieldu38 Messages postés 11 Date d'inscription mardi 22 janvier 2019 Statut Membre Dernière intervention 7 février 2019
Modifié le 22 janv. 2019 à 18:41
peut-être que je dois supprimer ce post et le remettre dans "bureautique, Excel" ? cela serait plus approprié ?
0