Bootrec /rebuildbcd : Erreur d'E/S [Résolu/Fermé]

Signaler
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
-
Messages postés
178792
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
3 juillet 2020
-
Bonjour,

J'ai Windows 8.1 d'installé sur mon PC ainsi que Linux Slackware 14.02 et Ubuntu 14.10.

- Depuis quelques temps je ne parvenais pas à démarrer slackware en mode graphique. Récemment j'ai remis à jour ma configuration en installant ubuntu 18.10 à la place de la 14.10 (DVD d'installation Unbuntu 18.10 pris dans un magazine de presse informatique). Sans que je comprenne pourquoi cela ma redonné l'accès à mon bureau graphique Slackware. Jusque là aucun souci avec Windows.

- Deux jours après l'installation d'ubuntu ce dernier m'a demandé une mise à jour que j'ai accepté et depuis je ne peux plus démarrer aucun de mes systèmes (je ne me souviens plus du message d'erreur de base). Même le dual boot Grub a disparu.

- Quand j'essaie de remettre manuellement les entrées de démarrage dans le gestionnaire de démarrage UEFI (F2 sur mon PC) cela ne fonctionne pas.

- Je peux démarrer depuis un DVD, Clé ou DD USB, par contre j'ai des temps de latence énorme à chaque fois quelque soit le support (parfois plus de 30 minutes par exemple pour afficher l'écran d'installation Linux ou Windows depuis un DVD ou la clé usb). Cela me prend donc un temps fou pour explorer les diverses solutions qui me sont proposées

- La récupération automatique à partir du dvd d'installation de W 8.1 échoue

J'ai décidé de tenter une récupération de ma partition EFI (pensant que le problème vient de là) via le dvd d'installation :
La commande bootrec /rebuildbcd trouve bien une partition Windows et me demande si je veux l'ajouter à la liste de démarrage. Mais quand je valide j'ai le message d'erreur suivant :"impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S".

Les pistes sérieuses que j'ai explorées jusqu’à maintenant :

- https://answers.microsoft.com/fr-fr/windows/forum/windows8_1-update/commandes-de-reparation-windows-81-en/d5f4f08e-50fb-4208-b4a2-c93861b8f58e
Ici je me suis arrêté à l'étape VII, je compte poursuivre avec l'étape VIII mais avant j'aimerais avoir un avis.

- https://docs.microsoft.com/fr-fr/windows/client-management/advanced-troubleshooting-boot-problems

Avant de poursuivre avec d'autres manipulations j'aimerais savoir si quelqu'un pourrait me donner quelques pistes à explorer.

Avant de tenter quoique ce soit à partir de Linux j'aimerais récupérer ma partition Windows car c'est celle que j'utilise au quotidien mais également parce que je ne suis pas encore très à l'aise avec les outils système de Linux.

Pour Info j'écris depuis un autre PC avec Windows 8 (pas 8.1) et j'ai également un autre PC avec Windows 7 pro à disposition si cela peut aider.

J'ai essayé d'être aussi clair que possible mais si vous avez besoin d'éclaircissement n'hésitez pas à demander. Je vous demanderai aussi de faire preuve de patience pour mes réponses car je ne peux consacrer que peu de temps pour le moment à cette problématique, mais je viendrai vous lire au moins une ou deux fois dans la journée.

Merci d'avance pour votre aide.

Configuration: config multiple :

PC 1 : Asus R752LJ-ty142h (configuration principale) / Intel I7 / 4 Go DDR3L / HDD 1 To


6 réponses

Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Bonsoir,

J'ai poursuivi avec le lien suivant : https://answers.microsoft.com/fr-fr/windows/forum/windows8_1-update/commandes-de-reparation-windows-81-en/d5f4f08e-50fb-4208-b4a2-c93861b8f58e

Etape VIII- :
VIII-1 : tout c'est bien passé
VIII-2 : idem
VIII-3 : idem
VIII-4 : quand je rentre la commande cd /d v:\EFI\Microsoft\Boot\ j'ai encore le même message d'erreur :
" impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S."

- J'ai tenté un check disk de la partition c:
rien à signaler

- quand je tente sur la partition v: sur laquelle devraient se trouver mon bcd :
"Le type du système de fichiers est RAW
CHKDSK n'est pas disponible pour RAW lecteurs"
Cette partition ne devrait-elle pas être en FAT32 ?

Merci d'avance à tous ceux qui voudront bien m'aider
Messages postés
178792
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
3 juillet 2020
21 396
Salut,

Erreur E/S + perte de partitions de disques.
Ce dernier est surement en train de mourir.

Tu peux vérifier l'état avec CrystalDiskInfo à partir d'un Live CD : https://www.malekal.com/verifier-materiel-de-ordinateur-live-cd-malekal/
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Bonsoir Malekal,

Je te remercie pour ton retour je n'ai pas eu le temps de voir le problème cette semaine.

Je vais tenter de créer une nouvelle partition EFI ou de reformater et réécrire celle qui ne fonctionne pas.
Si ça ne marche pas j'analyserai le disque avec ton logiciel.

Je reviendrai pour dire le résultat dès que possible.

Salut,

Démarre sur le DVD W8 en choisissant "réparer l'ordinateur", et va à l'invite de commandes. Et donne une photo du résultat de

diskpart
list disk
sel disk 0
list vol
list part
exit
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Bonjour uby-kitty

Merci de consacrer un peu de temps à mon problème.

Voici une photo :

J'avais déjà commencé à supprimer et recréer la partition efi . Le partitionnement est en cours.
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Désolé ce n'est pas passé depuis mon téléphone:

Il y a une seconde partition système de 14 Go passée en raw. Il faudrait dire pourquoi il y en a deux. Et il faudra créer les fichiers de démarrage avec

bcdboot c:\windows /l fr-fr

Mais la seconde partition efi va perturber la commande, je le crains. Il faudrait la supprimer ou la convertir. Tu as sûrement merdouillé avec gparted en ajoutant un drapeau boot sur une partition NTFS ou ext4.
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Pour le moment le formatage est toujours à 0% alors que je l'ai lancé entre 22:00 et 22:15 (je n'ai pas fait attention).
Je pense que Malekal a raison mon disque est probablement en train de mourir.
Si ça réussi je tenterai la commande bcdboot mais ça l'air plutôt mal parti.

Pour la partition de 14 Go en Raw, de mémoire il me semble que c'est un espace non alloué, sinon je ne vois pas ce que ça peut être.
La dernière fois que j'ai créé des partitions pour mes Linux je sais qu'il me restait environ 14 ou 15 Go non alloués, que je gardais en réserve pour installer une distrib en mode texte (install minimaliste) pour me faire la main.
Il est possible que ce soit aussi une tentative de recréer l'EFI sans effacer celle de 100 Mo, du coup Windows l'a créé dans l'espace non alloué qu'il me restait. Je dis ça car elle apparait en partition System dans la commande "list part"
Messages postés
178792
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
3 juillet 2020
21 396 >
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020

oui forte de chance vu tous les messages d'erreurs et autres problèmes.
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Je tenterai l'analyse du disque ce week-end avec CrystalDiskInfo quand même pour être sur avant d'acheter un nouveau disque.

Je pense que je peux fermer le problème du coup.

Merci pour votre aide.
Messages postés
104
Date d'inscription
dimanche 11 août 2002
Statut
Membre
Dernière intervention
19 juin 2020
8
Bonsoir à tous,

Petite mise à jour concernant mon problème même si j'ai déjà passé le sujet en résolu, ça pourra peut-être servir à quelqu'un ayant eu un problème similaire.

Je vous écrit depuis mon PC qui :
- ne démarrait plus ni sur Windows 8.1, ni sur Ubuntu ni sur Slackware.
- ma partition EFI était passée en RAW
- les manipulations classiques que j'ai essayées et mentionnées dans mes premiers posts ne fonctionnaient pas
- les options de réparations depuis le DVD de Windows ne fonctionnaient pas.

J'ai donc tenté la chose suivante :
- démarrage depuis un live dvd de kubuntu
- tentative de réparation du démarrage avec boot repair - sans succès
- formatage de la partition EFI en fat32 avec gparted - Réussi
- Nouvelle réparation de Grub avec boot Repair - réussi
- retour sur le Dvd Windows options avancées et ligne de commandes :
- j'ai assigné la lettre v: au volume de la partition EFI
- j'ai créé les répertoires Microsoft\Boot manuellement dans v:\EFI
- cd /d v:\EFI\Microsoft\Boot\ pour me placer dans le répertoire Boot\
- j'ai lancé la commande bcdboot c:\Windows /l fr-fr /s v: /f ALL

Après un redémarrage dans le gestionnaire EFI l'entrée pour Bootloader Manager de Windows est réapparue comme avant et Windows démarre normalement.
A première vue je n'ai aucune perte de Données.
Je n'ai pas encore vérifié si mes entrées de démarrage de Grub sont toujours valides (elles ont peut-être été effacées) mais en tout cas c'est bel et bien résolu cette fois-ci.

Au final je ne sais pas si le disque est défectueux je l’analyserai avec l'utilitaire de Malekal après les fêtes pour savoir si je dois prévoir un nouveau disque.

Bonne soirée et très bonne fêtes à tous.

Messages postés
178792
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
3 juillet 2020
21 396
Tu peux télécharger CrystalDiskInfo pour vérifier.