Formule si avec plusieurs données [Résolu/Fermé]

Signaler
Messages postés
49
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
4 octobre 2019
-
Messages postés
49
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
4 octobre 2019
-
Bonjour,

Je suis incapable de faire entrer toutes mes données je vous explique :

J'ai un fichier qui a des numéros ex 403256, 412563, 425662, 235652, 223552, 001658, 525555 etc et chaque numéro est attitré a un nom de ville ex: ceux débutant par 40,41,42 associe a MTL ceux par 22, 23 a Quebec ceux en 00 et 52 par Sherbrooke etc. je dois donc faire la formule =si(ma cellule ex D3 =40,41,42; MTL; rien si(22,23; QC; rien et ainsi de suite comment faire ma formule afin que toutes mes données s'y retrouvent?

Merci pour votre aide et bonne soirée

2 réponses

Messages postés
2129
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
24 septembre 2020
283
Bonjour,
Si les données sont en Colonne D à partir de D2 et au format texte,
en E2:
=SI(OU(GAUCHE(D2;2)={"40";"41";"42"});"MTL";SI(OU(GAUCHE(D2;2)={"22";"23"});"QC";SI(OU(GAUCHE(D2;2)={"00";"52"});"SB";"")))
A compléter si besoin
Cdlt
Messages postés
49
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
4 octobre 2019

Merci
Messages postés
12693
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
24 septembre 2020
2 025
Bonjour à vous deux

Ou avec une table de correspondance et une simple formule RECHERCHEV
exemple : https://mon-partage.fr/f/HmFvOIFe/
Cela a l'avantage de pouvoir modifier ou rallonger des éléments dans la table sans avoir à mpdifier toutes les formules
Dans la table de correspondance les 20 etc doivent être entrés en texte (précédés d'une apostrophe)
La table de correspondance peut se placer dans une autre feuille au besoin

Cdlmnt
Via

Messages postés
49
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
4 octobre 2019

Merci après avoir fait l'essaie pour les deux votre méthode me convenait mieux.