Fonction sommeprod [Résolu/Fermé]

Signaler
Messages postés
16
Date d'inscription
samedi 3 février 2018
Statut
Membre
Dernière intervention
4 juillet 2019
-
Messages postés
16
Date d'inscription
samedi 3 février 2018
Statut
Membre
Dernière intervention
4 juillet 2019
-
Bonjour tout le monde,

svp j'ai besoin d'aide avec la fonction sommeprod ( ou une solution avec une autre fonction)

voilà,
je veux faire la somme de la colonne J de la feuille2 , qui correspondant aux critères suivants;
- catégorie de la colonne L de feuille2 = b5
- mois de la colonne M de la feuille2 = mois(c3)

j'ai essayé avec cette formule mais elle me renvoie erreure de valeur
SOMMEPROD((Feuille2!$J:$J)*(MOIS(Feuille2!$M:$M=MOIS(C3)))*(Feuille2!$L:$L=B5))

merci d'avance

2 réponses

Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
222
Bonjour,

Sans exemple, au pif

=SOMMEPROD((MOIS(Feuille2!M:M)=MOIS(Feuille2!C3))*(Feuille2!L:L=B5)*(Feuille2!J:J))


à condition que C3 soit une date
Messages postés
16
Date d'inscription
samedi 3 février 2018
Statut
Membre
Dernière intervention
4 juillet 2019

merci M-12
mais aussi, ca ne marche pas
Messages postés
16
Date d'inscription
samedi 3 février 2018
Statut
Membre
Dernière intervention
4 juillet 2019

ci joint l'exemple de mon fichier
https://www.cjoint.com/c/HIejf5uUDlL
Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
222
Re,

Le problème vient du fait de prendre toutes les colonnes M - L - J, mais la colonne J à un total et sous total et il n'y a pas de date ou Ref en colonne M et L

A tester
https://www.cjoint.com/c/HIejuRgpcyu
Messages postés
16
Date d'inscription
samedi 3 février 2018
Statut
Membre
Dernière intervention
4 juillet 2019

merci M-12
votre formule fonctionne très bien.

merci encore et bonne journée