Si et Si et Si (Oui beaucoup de Si ahah)

Résolu/Fermé
dams63100 Messages postés 562 Date d'inscription vendredi 3 avril 2009 Statut Membre Dernière intervention 1 novembre 2023 - Modifié le 28 août 2018 à 19:07
dams63100 Messages postés 562 Date d'inscription vendredi 3 avril 2009 Statut Membre Dernière intervention 1 novembre 2023 - 28 août 2018 à 19:55
Bonsoir à tous et à toute !

Je me perds dans mes formules, je demande donc votre aide,

J'aimerais dire (en gros) que
A : si D20-C21 est < à 0 = 0
B : si D20-C21 est > à C21 = C21
C : si D20-C21 est entre 0 et C21, laisser la cellule (qui serait le résultat de D20-C21 et non une case vide)

J'ai bidouillé mais ça marche pas vraiment il me manque un truc sur ma formule :

Elle fonctionne pour le cas A et C mais pas pour le B (Elle affiche "0")
=SI(ET(D20-C21>0;D20-C21<C21);SI((D20-C21)>=C21;C21;(D20-C21));"0")

Mon premier essai fonctionne pour le cas A et B mais pas pour le C (Elle affiche "FAUX")
=SI((D20-C21)<=0;0;SI((D20-C21)>=C21;C21))

Merci d'avance pour celui ou celle qui va m'aider ;)

A voir également:

1 réponse

Raymond PENTIER Messages postés 58548 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 juillet 2024 17 151
28 août 2018 à 19:16
=SI(D20-C21<=0;0;SI(D20-C21>=C21;C21;D20-C21))
qu'on peut aussi écrire
=SI(D20<=C21;0;SI(D20>=2*C21;C21;D20-C21))
1
Raymond PENTIER Messages postés 58548 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 juillet 2024 17 151
28 août 2018 à 19:18
... et si ta formule affiche FAUX c'est parce que tu as oublié de mettre
;(D20-C21) à la fin !
0
dams63100 Messages postés 562 Date d'inscription vendredi 3 avril 2009 Statut Membre Dernière intervention 1 novembre 2023 44
28 août 2018 à 19:55
Ah ben oui c'est vrai que maintenant je la vois bien la fin manquante..

Merci beaucoup, probleme résolut ! :)
0