Si tout est OK = vert sinon rouge

Signaler
-
Messages postés
32532
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
26 juillet 2021
-
Bonjour,


Je débute encore sur Excel et j'aimerais mettre une fonction me permettant de voir que l'ensemble de mes colonnes sont en "OK" alors vert si "NOK" le résultat devra être rouge (en pourcentage serait l'idéal)

je m'explique
ex colonne C où se trouve le résultat
de la colonne D à N les résultats (choix entre OK et NOK)
si tout est OK je voudrais que ce soit à 100% en vert
si tout n'est pas OK alors en rouge avec le pourcentage restant avant d'être à 100% soit tout OK

je ne sais pas si c'est assez clair ^^

Si une âme charitable veut bien m'aider j'en serais ravie

Cordialement

1 réponse

Messages postés
32532
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
26 juillet 2021
7 829
Bonjour,

En C1 tu peux mettre une formule pour le calcul du %, avec un format de cellule % :
=NB.SI(D1:N1;"OK")/NB.SI(D1:N1;"*")


Puis tu crées des MFC (Mise en Forme Conditionnelle) sur C1 :
- regles de mise en surbrillance/egal à/100% ==> vert
- regles de mise en surbrillance/inferieur à/100% ==> rouge

et tu dupliques vers le bas la cellule C1