Calculer le nombre d'une colonne avec conditions

Résolu/Fermé
kittykatmew Messages postés 2 Date d'inscription jeudi 16 août 2018 Statut Membre Dernière intervention 21 août 2018 - Modifié le 16 août 2018 à 11:26
kittykatmew Messages postés 2 Date d'inscription jeudi 16 août 2018 Statut Membre Dernière intervention 21 août 2018 - 21 août 2018 à 10:14
Bonjour,
Je cherche à calculer le nombre total d'hommes et de femmes d'une colonne D1 , avec la condition que la colonne A1 soit non vide.
Pour le moment j'applique la formule NB.SI(D2:D5; "M") pour trouver les hommes et =NB.SI(D2:D5; "F")pour les femmes.
Le soucis c'est que je délimite les cases de calcul manuellement, et que je voudrais que ça le fasse automatiquement et prenant en compte la colone A1.

J'espère que je suis assez claire
Merci par avance !

Voici un exemple de tableau.
A voir également:

1 réponse

_Ritchi_ Messages postés 21236 Date d'inscription samedi 17 mars 2007 Statut Contributeur Dernière intervention 29 mai 2024 6 063
16 août 2018 à 12:24
Bonjour,

Je te propose cette évolution qui ne comble pas encore la délimitation manuelle des cases de calcul:
En D8:
=NB.SI.ENS(D2:D5;"=M";A2:A5;"=*")

En D9:
=NB.SI.ENS(D2:D5;"=F";A2:A5;"=*")


Suggestion:
Mettre ces deux cases D8 et D9 en entête de tableau, ainsi tu pourras indiquer non plus les plages "A2;A5" et "D2;D5", mais les plages "A4:A999" et "D4:D999" (ou encore plus si tu as énormément de noms à gérer):


Ritchi
1
_Ritchi_ Messages postés 21236 Date d'inscription samedi 17 mars 2007 Statut Contributeur Dernière intervention 29 mai 2024 6 063
Modifié le 17 août 2018 à 21:39
Bonjour,

Amélioration des formules afin de ne plus être contraint de délimiter les cases de calcul manuellement:
=NB.SI.ENS(D:D;"=m";A:A;"=*")
=NB.SI.ENS(D:D;"=f";A:A;"=*")

La seule contrainte de cela est que les cellules qui comptent le nombre d'hommes et de femmes ne soient pas dans les colonnes A et D car ces deux colonnes sont utilisées dans la formule et donc cela provoquerait une erreur. Du coup, par rapport à la capture précédente, j'ai décalé en colonne C le calcul du nombre de personnes masculines et féminines:


Ritchi
0
kittykatmew Messages postés 2 Date d'inscription jeudi 16 août 2018 Statut Membre Dernière intervention 21 août 2018
21 août 2018 à 10:14
Merci beaucoup pour votre réponse, la formule fonctionne très bien!
Je vais maintenant tester d'autre formule avec la même base, comme calculer la moyenne d'âge entre homme femme, l'âge maxi, l'âge mini ect..

Belle journée!

Kat
0