Calcul du nombres de jours ouvrés

Résolu/Fermé
Nad - 30 juil. 2018 à 10:29
 Nad - 30 juil. 2018 à 15:11
Bonjour,

Je souhaiterais utiliser la fonction jours ouvrés d'excel pour calculer des dates d'échéances qui ne doivent pas prendre en compte les week-ends (samedi et dimanche) et les jours fériés. J'ai regardé sur plusieurs forums mais rien n'y fait la fonction me renvoie toujours 0 auriez-vous une solution ?

Je vous joins le ficher : https://www.cjoint.com/c/HGEiC5JngcX

Merci

5 réponses

DjiDji59430 Messages postés 3670 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 23 novembre 2022 560
30 juil. 2018 à 10:58
Bonjour,

https://www.cjoint.com/c/HGEi1mC3VAR

Calculs des féries faux ==>reference circulaire

Pour 2018,prendre comme reference $B$1 qui est ton année de reference . Et le calcul du nouvel an 2019, c'est noel 2018+7


Crdlmt
0
Merci de votre réponse.

En faite dans mon calcul je voudrais compter par la date d'échéance 90 jours après mon lavage. Mais si cette journée tombe un week end ou un jour férié, dans ce cas là le faire avant. Vous seriez comment faire ?
0
PHILOU10120 Messages postés 6170 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 24 novembre 2022 744
30 juil. 2018 à 12:58
Bonjour Nad

Votre fichier modifié en tenant compte de votre dernière question.

https://cjoint.com/c/HGEk6hVFGpx
0
Merci mais je ne comprend pas trop la formule.
Pur certains le lavage a été décalé à un mois plus tard alors que ça ne devrait pas.
Par exemple j'ai eu un lavage le 4/06, le prochain devrait être le 2/09 mais avec la nouvelle formule ça me le décale au 9/10.

=SI(SIERREUR(SERIE.JOUR.OUVRE($F4;$D4;Fériés);"")="";"";SI(JOURSEM(SIERREUR(SERIE.JOUR.OUVRE($F4;$D4;Fériés);""))=6;SIERREUR(SERIE.JOUR.OUVRE($F4;$D4;Fériés);"")-1;SIERREUR(SERIE.JOUR.OUVRE($F4;$D4;Fériés);"")))

Si j'ai bien compris la formule cela me calcule le prochain jour de lavage en fonction des jours ouvrés ? Or, je voudrais compter les weeks end dans la formule. Mais que si le prochain lavage est prévu un week-end ou un jour férié, que ça me le décale avant
0
PHILOU10120 Messages postés 6170 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 24 novembre 2022 744
Modifié le 30 juil. 2018 à 14:37
Bonjour Nad

Le fichier modifié la colonne supplémentaire compte tous les jours et décales à moins 1 si c'est samedi et 2 si c'est un dimanche
Vous n'avez pas besoin de la fonction SERIE.JOUR.OUVRE dans ce cas

https://www.cjoint.com/c/HGEmE2TiPmx

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 141
Modifié le 30 juil. 2018 à 14:45
Bonjour,

=SERIE.JOUR.OUVRE(F4+D4+1;-1;$S$5:$S$19) 

Mais tu as mis n'importe quoi dans tes fériés.
Remplace $S$19 par $S$3 dans toutes tes formules sinon SERIE.JOUR.OUVRE n'aime pas du tout.
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0
Ah oui en effet maintenant ça marche!!!
Merci beaucoup !!!
0