Calculer une moyenne toute les 3 lignes.

Résolu/Fermé
ehones4
Messages postés
4
Date d'inscription
mardi 29 mai 2018
Statut
Membre
Dernière intervention
29 mai 2018
- 29 mai 2018 à 19:19
ehones4
Messages postés
4
Date d'inscription
mardi 29 mai 2018
Statut
Membre
Dernière intervention
29 mai 2018
- 29 mai 2018 à 21:27
Bonjour,

Ca fait deux heures que je bataille sur ça, mais mon jeu de données est trop grand pour que je puisse le faire sans passer par une formule. J'ai bien saisi qu'il fallait que j'utilise les fonction DECAL et MOYENNE, mais je n'y arrive décidément pas.

Je voudrais en effet calculer la moyenne toutes les trois lignes des colonnes "A" et "B" et afficher cette moyenne dans les colonne "C" et "D" respectivement.

Imaginez mon tableau comme ceci :
A B C D
1 1 moyenne (A1:A3) moyenne (B1:B3)
2 2 moyenne(A4:A6)
3 3 etc etc
4 4
5 5
6 6

Merci de me venir en aide/

4 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
Modifié le 29 mai 2018 à 19:50
Bonsoir
si les valeurs de A commencent en ligne 2, pour avoir la moyenne cherchée:
à tirer sur la hauteur
=SI(MOD(LIGNE();3)=1;MOYENNE(DECALER(A2;;;-3));"")
si on commence sur ligne &
=SI(MOD(LIGNE();3)=0;MOYENNE(DECALER(A1;;;-3));"")
et idem pour B évidemment
crdlmnt
0
ehones4
Messages postés
4
Date d'inscription
mardi 29 mai 2018
Statut
Membre
Dernière intervention
29 mai 2018

29 mai 2018 à 20:05
Merci pour cette réponse ultra rapide. Mais ca ne fonctionne pas de mon côté, tout est blanc.

De plus, sauf erreur de ma part, ta solution laisse des blancs entre chaque moyenne dans mes colonnes C et D.
J'aimerai que toute les moyennes soient a la suite dans la colonne si possible, sans blanc.

ps : je commence effectivement ligne 2

Merci
0
ccm81
Messages postés
10275
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
17 mai 2022
2 287
29 mai 2018 à 20:21
Bonjour

Peut être comme ça ?
https://www.cjoint.com/c/HEDsux4MwGB

Salut à Vaucluse en passant

Cdlmnt
0
ehones4
Messages postés
4
Date d'inscription
mardi 29 mai 2018
Statut
Membre
Dernière intervention
29 mai 2018

29 mai 2018 à 21:00
Merci infiniment a vous deux, ça fonctionne très bien ccm81 !
Bonne soirée
0
ccm81
Messages postés
10275
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
17 mai 2022
2 287
29 mai 2018 à 21:08
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en haut à droite, la roue dentée)


Bonne soirée
0
ehones4
Messages postés
4
Date d'inscription
mardi 29 mai 2018
Statut
Membre
Dernière intervention
29 mai 2018

29 mai 2018 à 21:27
C'est fait, merci
0