Afficher trois valeurs dans une seule cellule [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mardi 24 avril 2018
Statut
Membre
Dernière intervention
24 avril 2018
-
Messages postés
3
Date d'inscription
mardi 24 avril 2018
Statut
Membre
Dernière intervention
24 avril 2018
-
Bonjour,


J'ai une feuille Excel dont la première colonne est la date, la deuxième le numéro du champ et la troisième le numéro du producteur. Soit par exemple: 19/04/18 10 41

Je souhaiterais faciliter la création du code traçabilité dans la quatrième colonne.

Ce code pour l'exemple ci dessus serait 16 04 10 41. Soit 16 pour le numero de la semaine (fonction =no.semaine), 04 pour le jour de la semaine soi jeudi (fonction =joursem, -1 car excel débute le dimanche) 10 pour le champ et 41 pour le producteur.

Est-il possible de compiler une formule dans une seule cellule afin d'obtenir ce code ? (sans création de colonne intermédiarie de préférence ??

D'avance merci

Pedro

2 réponses

Messages postés
16367
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2021
3 112
Bonjour

=NO.SEMAINE(A1)&" "& JOURSEM(A1;2)&" "&B1&" "&C1
Messages postés
3
Date d'inscription
mardi 24 avril 2018
Statut
Membre
Dernière intervention
24 avril 2018

ok alors là merci michel, au top.
et pour pousser le délire un peu plus loin, comment afficher 04 et non 4 pour le joursem ?
Messages postés
16367
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2021
3 112
le délire classe affaires
=TEXTE(JOURSEM(A1;2);"00")
Messages postés
3
Date d'inscription
mardi 24 avril 2018
Statut
Membre
Dernière intervention
24 avril 2018

nickel de chez nickel merci
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 436
Bonjour,

si par exemple tu as la date en A2, 10 en B2 et 41 en C2

=NO.SEMAINE(A2)&" "&JOURSEM(A2)-1&" "&B2&" "&C2

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...