Récupérer valeurs du tableau, afficher selon prio

Résolu/Fermé
Excelprblm - 4 mars 2018 à 16:18
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 - 4 mars 2018 à 17:50
Bonjour,
Désolé du titre peu explicite.

Voilà mon problème :
J'ai un tableau comprenant un nombre défini de résultats (5 résultats possibles, disons "1"=Faible et "5"=Critique) qu'on entre dans le tableau à l'aide de la validation de données. Pour ce tableau je souhaiterai avoir une cellule affichant le résultat du tableau selon un ordre de priorité.
Si dans le tableau il y a ne serait ce qu'un seul résultat "5", il faut que cette valeur soit affichée dans la cellule résultat. Et ainsi de suite, si il n'y a pas de "5" mais un "4" il faut que le "4" soit affiché en priorité.

Pour info, il s'agit de valeurs texte, les chiffres que j'utilise sont juste des exemples.

Je sais qu'une formule permet de faire ça, mais je ne sais vraiment pas quoi taper sur Google pour trouver.

Merci !


4 réponses

PapyLuc51 Messages postés 3885 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 7 février 2023 1 228
4 mars 2018 à 16:52
Bonjour

Je verrai plutôt une suite de SI(NB.SI()) imbriqués en commençant par le plus élevé pour terminer par le moins élevé
par exemple

=SI(NB.SI(Tableau;"bbbb")>0;"bbbb";SI(NB.SI(Tableau;"aaaa")>0;"aaaa";""))

Cordialement
1
Oui ! Ca a marché, merci beaucoup !
0
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 2 550
4 mars 2018 à 17:50
Salutations amicales PapyLuc

Et oui les grands esprits se rencontrent comme on dit ☺
0
ccm81 Messages postés 10520 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 24 janvier 2023 2 336
4 mars 2018 à 16:39
Bonjour

Pas sûr d'avoir bien compris mais
=MAX(A1:A10)
te donne le maxi de la plage A1:A10

Cdlmnt
0
Merci de ton aide,
Est ce que je peux m'en servir pour du texte ? Dans mon tableau les résultats sont du texte, Est ce qu"il y a pas un moyen de dire que le texte "aaaaa" a une valeur plus élevée que "bbbbb" ?
0
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 2 550
4 mars 2018 à 16:52
Bonjour à vous deux

La problématique est alors plus de dénombrer les "Critique" dans la plage et si résultat >0 afficher Critique, sinon dénombrer le critère suivant, disons par ex Elevé et l'afficher si résultat >0, etc, non ?
En ce cas il faut imbriquer des SI :
=SI(NB.SI(A1:A10;"Critique")>0;"Critique";SI(NB.SI(A1:A10;"Elevé")>0;"Elevé"; etc ...

Cdlmnt
Via
0
PapyLuc51 Messages postés 3885 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 7 février 2023 1 228
4 mars 2018 à 17:02
Salutations Via

la même idée à quelques secondes d'écart. ;-)

Cordialement
0
ccm81 Messages postés 10520 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 24 janvier 2023 2 336
4 mars 2018 à 16:54
Pour du texte, on ne peut pas utiliser la fonction MAX
Pour aller plus loin, peux tu envoyer un bout de ton fichier sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
0